Bug 121909 - no data in /proc/partitions
no data in /proc/partitions
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 20:38 EDT by Don Buchholz
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 09:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Buchholz 2004-04-28 20:38:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
All I get are column headers, no numbers or anything else, when I cat
/proc/partitions on the RHEL-3.0/ES server I am building.

  # cat /proc/partitions
  major minor  #blocks  name     rio rmerge rsect ruse wio wmerge
wsect wuse running use aveq

I am attaching an IBM FAStT Storage Server and /proc/partitions has
always been important for diagnosis of problems.



Version-Release number of selected component (if applicable):
kernel-2.4.21-9.0.1.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. Boot system:
    -- SAN drive is /dev/sda.
    -- Operating system partitions are on /dev/sdb.

2. cat /proc/partitions

3. Unload the qla2200 and qla2200_conf drivers (e.g. to upgrade them).

4. cat /proc/partitions


Actual Results:  With QLogics driver loaded:
# cat /proc/partitions
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect
wuse running use aveq

   8     0  209715200 sda 12 0 24 40 0 0 0 0 0 10 40
   8    16    8886272 sdb 113822 55555 982086 875900 37830 65835
831510 11347010 0 388350 12227990
   8    17     103981 sdb1 2941 4312 14506 36230 22 7 58 4470 0 6070 40700
   8    18    4008501 sdb2 92896 9007 815194 621230 31793 64580 773400
11038090 0 331660 11664390
   8    19    1720215 sdb3 160 0 320 1040 0 0 0 0 0 170 1040
   8    20          1 sdb4 3 0 6 0 0 0 0 0 0 0 0
   8    21    1720183 sdb5 11470 24396 103130 137180 2010 1193 25618
174110 0 64080 311290
   8    22    1328134 sdb6 5292 17840 46810 76620 4005 55 32434 130340
0 78110 206960

After QLogics driver is unloaded:
# cat /proc/partitions 
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect
wuse running use aveq

After the QLogics driver is reloaded, all entries return as expected.


Expected Results:  I expected to continue seeing information about the
seven (7) partition entries associated with sdb.

Additional info:

Bug #107960 might be related, but it is marked for a different platform.
Comment 1 Ankur Jain 2004-05-21 14:11:37 EDT
I am using kernel 2.4.19-openmosix7. Disk partition statistics are 
not available in this kernel too.

The output from cat /proc/partitions is

major minor  #blocks  name

   3    64   58633344 hdb
   3    65     514048 hdb1
   3    66    1052257 hdb2
   3    67   57062880 hdb3

Is there any patch available to fix this?
Comment 2 Doug Ledford 2004-06-03 20:24:32 EDT
Don:

What driver is used for the OS disk (/dev/sdb)?  I'm assuming it's not
on the qlogic driver or else upgrading it would be impossible with the
system running.  I'm asking because I'm unable to reproduce the
problem here.  Either it was fixed between 2.4.21-9.EL and the current
sources I'm looking at or something weird is happening on your
particular configuration that might be driver related.
Comment 3 Don Buchholz 2004-06-04 01:03:50 EDT
It is an IBM ServeRAID volume.  The driver is "isp".  Version info in
messages file:  "IBM PCI ServeRAID 6.10.52  Build 563 <ServeRAID 4Lx>".
Comment 4 Tom Coughlan 2004-06-04 07:08:01 EDT
For what it is worth, both the IBM ServeRAID (ips driver) and the
QLogic driver were updated in U2 (2.4.21-15.EL).
Comment 5 Don Buchholz 2004-06-04 14:30:33 EDT
I expect to apply the U2 (and later) updates sometime in
the next 4-6 weeks.  I'll see if the problem still exists
in the updated versions.
Comment 6 Tom Coughlan 2004-12-21 17:14:49 EST
Any update on the results of testing U2 (or U3 or U4)?
Comment 7 Tom Coughlan 2005-09-19 09:48:59 EDT
Since we have not received the feedback we requested, we will assume the problem
was not reproduceable or has been fixed in a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 

Note You need to log in before you can comment on or make changes to this bug.