Bug 12193 - RAID-1 Install Boot Configuration
RAID-1 Install Boot Configuration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 07:50 EDT by Neil Darlow
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-21 18:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Darlow 2000-06-13 07:50:13 EDT
Doing an NFS install of Winston with:

    /dev/hda1, /dev/hdc1    /dev/md0    RAID-1    /boot
    /dev/hda2, /dev/hdc2    /dev/md1    RAID-1    /
    /dev/hda5, /dev/hdc5    /dev/md2    RAID-1    /home
    ...        ...

/dev/hda1 and /dev/hdc1 marked as bootable with fdisk.

/etc/lilo.conf is created with:

    boot=/dev/hda    <--- not /dev/md0

Undelying VC of Installation reports:

    Fatal: Sorry, don't know how to handle device 0x0900

System won't boot.
Comment 1 Michael Fulbright 2000-06-13 17:59:08 EDT
How large was your boot partition?
Comment 2 Neil Darlow 2000-06-14 04:08:33 EDT
The recommended 16MB.

Here's output from "df" for an equivalent installation of 6.2
which works ok.

Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/md1                254635     33760    207727  14% /
/dev/md0                 15860      2892     12143  19% /boot
/dev/md2               3105396     10044   2937608   0% /home
/dev/md3               1035148        48    982516   0% /tmp
/dev/md4               2069944    939108   1025684  48% /usr
/dev/md5               1035148     14012    968552   1% /usr/local
/dev/md6               2069944     13140   1951652   1% /var

All partitions are RAID-1.

/dev/md0  /dev/hda1  /dev/hdc1
/dev/md1  /dev/hda2  /dev/hdc2
/dev/md2  /dev/hda5  /dev/hdc5
/dev/md3  /dev/hda6  /dev/hdc6
/dev/md4  /dev/hda7  /dev/hdc7
/dev/md5  /dev/hda8  /dev/hdc8
/dev/md6  /dev/hda9  /dev/hdc9
/dev/md7  /dev/hda10 /dev/hdc10  Swap

The installer lets you put swap onto RAID. The raidtools document:
Software-RAID-HOWTO.txt advises this is UNSAFE. Is this true?
Comment 3 Brock Organ 2000-06-15 18:49:27 EDT
hmmm ... I am unable to reproduce this behavior (see info below...) ... breaking
it down into individual components ... are you able to do a subset of the above
(such as a minimal install) for just the / and /boot partitions ...?  

% df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/md1              197M  110M   77M  59% /
/dev/md0               23M  2.8M   19M  13% /boot
/dev/md2               99M   13k   93M   0% /mnt/md2
/dev/md3               99M   13k   93M   0% /mnt/md3
/dev/md4               99M   13k   93M   0% /mnt/md4
/dev/md5               99M   13k   93M   0% /mnt/md5
/dev/md6               99M   13k   93M   0% /mnt/md6

% fdisk -l /dev/hda /dev/hdc

Disk /dev/hda: 255 heads, 63 sectors, 1650 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1         3     24066   fd  Linux raid autodetect
/dev/hda2             4       204   1614532+  fd  Linux raid autodetect
/dev/hda3           205      1650  11614995    5  Extended
/dev/hda5           205       217    104391   fd  Linux raid autodetect
/dev/hda6           218       230    104391   fd  Linux raid autodetect
/dev/hda7           231       243    104391   fd  Linux raid autodetect
/dev/hda8           244       256    104391   fd  Linux raid autodetect
/dev/hda9           257       269    104391   fd  Linux raid autodetect
/dev/hda10          270       282    104391   fd  Linux raid autodetect

Disk /dev/hdc: 255 heads, 63 sectors, 784 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1             1         3     24066   fd  Linux raid autodetect
/dev/hdc2             4        29    208845   fd  Linux raid autodetect
/dev/hdc3            30       784   6064537+   5  Extended
/dev/hdc5            30        42    104391   fd  Linux raid autodetect
/dev/hdc6            43        55    104391   fd  Linux raid autodetect
/dev/hdc7            56        68    104391   fd  Linux raid autodetect
/dev/hdc8            69        81    104391   fd  Linux raid autodetect
/dev/hdc9            82        94    104391   fd  Linux raid autodetect
/dev/hdc10           95       107    104391   fd  Linux raid autodetect

Comment 4 Neil Darlow 2000-06-16 11:04:29 EDT
Repeated exercise with following RAID configuration:

    /dev/hda1    /dev/hdc1    /boot    16M
    /dev/hda2    /dev/hdc2    swap     64M
    /dev/hda5    /dev/hdc5    /        Remainder of 10G drive

No problem this time.

I wonder if the original problem occurred because I exited the installer
before raid construction was complete.

If this is likely to cause trouble perhaps it shouldn't be possible to
activate the Exit button until this operation is complete (with a suitable
warning also).
Comment 5 Brock Organ 2000-07-17 18:20:45 EDT
hi neil, have you had any luck reproducing the original problem with beta3 ...?
Comment 6 Glen Foster 2000-07-18 14:40:37 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 7 Neil Darlow 2000-07-18 14:47:29 EDT
/etc/lilo.conf still created with:  boot=/dev/hda  <-- should be /dev/md0

Exiting the installer immediately before RAID reconstruction complete no longer
causes
a problem.

System boots (don't expect it will if /dev/hda fails) after which I manually
edited
/etc/lilo.conf so:  boot=/dev/md0.

Re-installed lilo (which reported it's actions for both /dev/hda and /dev/hdc)
and restarted
system. Subsequent boot was OK.

So, some improvement, but not quite there yet.
Comment 8 Erik Troan 2000-07-21 18:43:23 EDT
Please retry this with beta 4 or 5. Beta 4 is not exhibiting this problem in the
lab.

If it reoccurs, reopen this bug asap.
Comment 9 Brock Organ 2000-07-21 18:47:46 EDT
Beta4 is using "boot=/dev/md0" in /etc/lilo.conf ...

Note You need to log in before you can comment on or make changes to this bug.