Bug 12195 - Norwegian keyboard not used in X
Norwegian keyboard not used in X
Status: CLOSED DUPLICATE of bug 12191
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 09:06 EDT by Kjartan Maraas
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-14 07:38:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2000-06-13 09:06:13 EDT
Choosing Norwegian language during install results in this
being used on the console, but not in X.
Comment 1 Brock Organ 2000-06-13 10:33:53 EDT
hmmm ... though there are a few spots of untranslated English text in the
install, using both boot.img and bootnet.img with a GUI install brings up X in
Norweigan for me ...
Comment 2 Brock Organ 2000-06-13 17:07:48 EDT
clarification from Kjartan:

> What I meant was that after the machine boots up again,
> I have norwegian keymappings on the console with "-" next
> to the right shift key and "/" as shift+7 etc. In X I have
> "/" on the key next to the right shift key (on the left that
> is) and something else on shift+7, ie US mapping. This is
> wrong and also not consistent.
> 
> Cheers
> Kjartan
Comment 3 David Balažic 2000-06-14 07:38:39 EDT
I had similar problem with redhat 6.2.
I selected Slovene as keyboard layout in text mode install
( the gfx mode had no ooption for Slovene keyboards ),
but X was US. 
Reason : no Slovene keyboard files present in the Xfree distribution.
They are using a slightly newer method called XKB.
Some guys in Slovenia created XKB files for Slovene keyboards,
which I also sent to redhat. It was also said that Slovene keyboard
will be part of Xfree 4.0 , but I didn't check it yet.

So either there is no XKB file for norwegian or it is set up incorrectly
by the installer ( there were many problems with keyboard setting in the
installer in the 6.x versions, see bugzilla ). With Xfree 3.x.x you can
disable XKB by setting an option in the XF86Config file, and then it
would just use the console settings. I don't know if this works with 4.0
too.
See bug #7555.
Comment 4 Michael Redinger 2000-06-16 08:56:43 EDT

*** This bug has been marked as a duplicate of 12191 ***

Note You need to log in before you can comment on or make changes to this bug.