Bug 121951 - firstboot uses wrong keyboard layout when rhgb runs
firstboot uses wrong keyboard layout when rhgb runs
Status: CLOSED DUPLICATE of bug 100686
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 06:14 EDT by David L Norris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L Norris 2004-04-29 06:14:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.14

Description of problem:
I selected the Dvorak keyboard layout during installation but
firstboot still uses a qwerty layout.

When rhgb runs before firstboot the keyboard layout is incorrect in
firstboot.

When rhgb does not run the keyboard layout in firstboot is correct.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select Dvorak keyboard layout during installation.
2. Boot newly installed system with rhgb enabled.
3. Attempt to type a username in firstboot's "Create User" step.
    

Actual Results:  I type "David" on the Dvorak keyboard and "Ha.gh" is
entered into the text box.

Additional info:

After reading Bug #100686 I removed /etc/sysconfig/firstboot, ran
"chkconfig --add firstboot", and rebooted.  I booted removing the
'rhgb' kernel argument and adding 'nogui' argument.  rhgb did not
start and firstboot had the proper Dvorak keyboard layout.  I tested
this on two systems.
Comment 1 Daniel Veillard 2004-09-13 12:37:15 EDT

*** This bug has been marked as a duplicate of 100686 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.