Bug 121953 (vm86-segv) - signal 11 in vm86() - used by X.org video drivers
Summary: signal 11 in vm86() - used by X.org video drivers
Status: CLOSED RAWHIDE
Alias: vm86-segv
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 122301 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-29 10:29 UTC by Laurent GUERBY
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 10:08:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci on the machine (1.17 KB, text/plain)
2004-04-29 10:30 UTC, Laurent GUERBY
no flags Details
working on FC1 (3.10 KB, text/plain)
2004-04-29 10:31 UTC, Laurent GUERBY
no flags Details
working log on FC1 (51.47 KB, text/plain)
2004-04-29 10:31 UTC, Laurent GUERBY
no flags Details
conf on FC2 (2.75 KB, text/plain)
2004-04-29 10:32 UTC, Laurent GUERBY
no flags Details
/var/log/messages (22.01 KB, text/plain)
2004-05-01 07:19 UTC, Laurent GUERBY
no flags Details
successful /var/log/messages (26.04 KB, text/plain)
2004-05-02 09:28 UTC, Laurent GUERBY
no flags Details
successful /var/log/Xorg.0.log (51.19 KB, text/plain)
2004-05-02 09:28 UTC, Laurent GUERBY
no flags Details

Description Laurent GUERBY 2004-04-29 10:29:17 UTC
After install, on first boot I get a screen asking
for display information (LCD 1024x768, millions of color)
I click ok and then everything goes black, I have to power off/on.
The machine is an ACER 1353 LM laptop.

I'll attach FC1 XFree logs and lspci

Xorg.setup.log

Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.4.21-4.ELsmp i686 [ELF] 
Current Operating System: Linux localhost.localdomain 2.6.5-1.327 #1
Sun Apr 18 04:51:55 EDT 2004 i686
Build Date: 15 April 2004
Build Host: tweety.devel.redhat.com
 
	Before reporting problems, check http://wiki.X.Org
	to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.5-1.327 (bhcompile@bugs.build.redhat.com)
(gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 Sun Apr 18
04:51:55 EDT 2004 
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Thu Apr 29 01:26:42 2004
(++) Using config file: "/tmp/tmpfkE8hPxorg.config"
(EE) VESA(0): vm86() syscall generated signal 11.

Comment 1 Laurent GUERBY 2004-04-29 10:30:01 UTC
Created attachment 99767 [details]
lspci on the machine

Comment 2 Laurent GUERBY 2004-04-29 10:31:07 UTC
Created attachment 99768 [details]
working on FC1

Comment 3 Laurent GUERBY 2004-04-29 10:31:41 UTC
Created attachment 99769 [details]
working log on FC1

Comment 4 Laurent GUERBY 2004-04-29 10:32:11 UTC
Created attachment 99770 [details]
conf on FC2

Comment 5 Mike A. Harris 2004-05-01 05:40:28 UTC
(EE) VESA(0): vm86() syscall generated signal 11.

This indicates that vm86() is broken somehow.  It has broken several
times in the 2.6.x kernel timeframe, and is likely a kernel bug.

Reassigning to kernel component.

Comment 6 Laurent GUERBY 2004-05-01 07:19:19 UTC
Created attachment 99857 [details]
/var/log/messages

This is /var/log/messages from boot to reboot, it shows nothing
particular to my unexpert eye. Let me know if I should install
another kernel RPM and try it.

Comment 7 Arjan van de Ven 2004-05-01 09:51:17 UTC
(EE) VESA(0): vm86() syscall generated signal 11.

is there anything more in that log ?


Comment 8 Laurent GUERBY 2004-05-01 10:45:47 UTC
No that's the last line, may be there's some option to make it more
verbose?

Comment 9 Arjan van de Ven 2004-05-01 18:10:32 UTC
ok build 347 is supposed to have this fixed; will be on
http://people.redhat.com/arjanv/2.6 in a few hours.

Comment 10 Laurent GUERBY 2004-05-02 09:27:24 UTC
Build 347 fixed the problem, many thanks. I'm attaching
/var/log/messages and Xorg.0.log.

Comment 11 Laurent GUERBY 2004-05-02 09:28:08 UTC
Created attachment 99870 [details]
successful /var/log/messages

Comment 12 Laurent GUERBY 2004-05-02 09:28:42 UTC
Created attachment 99871 [details]
successful /var/log/Xorg.0.log

Comment 13 Mike A. Harris 2004-05-04 18:37:04 UTC
*** Bug 122301 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.