Bug 121961 - Unable to set MTU on Broadcom 5704 1000Base-T NIC (bcm5700 driver)
Unable to set MTU on Broadcom 5704 1000Base-T NIC (bcm5700 driver)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 07:16 EDT by José Carlos Ramírez Pérez
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-29 07:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description José Carlos Ramírez Pérez 2004-04-29 07:16:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Hello, I'm having a problem with a pair of Broadcom 5704 1000Base-T 
ethernet cards. When I try to set up a fixed value for MTU, to lower 
it to 1400 (to workaround a problem related with tunneling ADSL 
lines), the network interface stops working (i.e. doesn't send or 
receive anything).

The driver version is 'Broadcom Gigabit Ethernet Driver bcm5700 with 
Broadcom NIC Extension (NICE) ver. 6.0.2 (02/14/03)' as shown in 
dmesg.

I have tried the same with a laptop (with Red Hat Fedora on it) and 
it works. May it be a problem with hardware/kernel driver...

Best regards,


Version-Release number of selected component (if applicable):
kernel 2.4.9-e.34smp, module bcm5700 6.0.2 (02/14/03)

How reproducible:
Always

Steps to Reproduce:
'ip link set eth0 mtu 1400'

or

'MTU=1400'
on /etc/sysconfig/network-scripts/ifcfg-eth0

Actual Results:  The NIC stops working.

Expected Results:  Reduce MTU to 1400 and continue working

Additional info:

The vendor says the 'mtu' parameter on *loadable module* only allows 
values from 1500 to 9000 (to enable jumbo frames). But I'm not 
touching this... (also tried but didn't happened anything).
Comment 1 Arjan van de Ven 2004-04-29 07:23:25 EDT
this module isn't shipped and thus not supported by us; I recommend
using the tg3 driver instead.

Note You need to log in before you can comment on or make changes to this bug.