Bug 121964 - USB broken in Kernel 2.6.5-1.327.
USB broken in Kernel 2.6.5-1.327.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 07:37 EDT by Ivo Sarak
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-29 19:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2004-04-29 07:37:47 EDT
Description of problem:
Enabling USB support will render systems to state where these are
unable to boot up.

Version-Release number of selected component (if applicable):
(This is vanilla FC2 Test3, no updates.)
kernel-2.6.5-1.327

How reproducible:
Always.

Steps to Reproduce:
1. Install FC3;
2. Enable USB support in the BIOS;
3. Let Kudzu to add USB modules;
4. Reboot the box;
  
Actual results:
System will not boot up, it will just stop at some point.

Expected results:
No stoppage.

Additional info:
Details of my 2 systems what do not start up with USB support enabled
are available:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121857
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121859
Comment 1 Ivo Sarak 2004-04-29 10:44:59 EDT
One more:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121933
Comment 2 Antti Markus 2004-05-03 01:55:04 EDT
This problem doesn't seem to be present on Intel hardware (Compal CL50
AKA Ordi Enduro CL50 Intel Centriono laptop).
Comment 3 Marshall Lewis 2004-05-05 22:36:10 EDT
I'm having this problem as well, the system doesn't actually hang, but
when usb modules are loaded cpu stays at 100% with most of it in hi
(hardware interupt? .. I'm not familiar with the new fields in top)
This happens with any kernel build 327 or later.  I have a 2.5.3
kernel build that worked (doesn't now because some of the dev updates
won't work with the older kernel) fine on the same machine.

I tried to debug this a little.. I'm not getting much in the way of
useful info from the kernel log.  But I did try removing all the usb
devices from the machine to see if that was the issue, and removing
the modprobe.conf and hwconf files to besure it wasn't them.. neither
had an effect, if the usb modules load, the system goes 100% cpu
utilization.

My system is an opteron with a via chipset.. motherboard is msi k8t
master2-far

Oh.. and when the usb-modules are loaded, nautilus consitently segfaults.

Right now I'm running with no usb modules loaded, which is kinda hard
since I have a usb mouse.. need to find an adapter : )


Comment 4 Marshall Lewis 2004-05-06 13:54:13 EDT
After a significate number of reboots, I believe that in my case this
was a resource conflict issue, but I'm not clear on why it didn't
appear prior to the 2.6.5 kernels.  I ended up disabling both comm
ports and the printer port in bios, and now it boots fine.

One thing that could be effecting this is that I'm having to boot with
acpi=off in order for my sata drive to work,.. I also have an adaptec
scsi card, and it seems to be claiming the same irq as my usb controllers.
Comment 5 Marshall Lewis 2004-05-15 13:58:33 EDT
A bios upgrade has allowed me to turn back on my comm and printer
ports...  all seems to be well for me now.
Comment 6 Alan Cox 2004-05-22 12:38:08 EDT
People seeing this might want to try booting with "acpi=off" as an
added boot option
Comment 7 Ivo Sarak 2004-05-22 16:17:12 EDT
"acpi=off" didn't fix it for me, only way to get the machine up was
not to load usb modules.
Comment 8 Ivo Sarak 2004-05-22 16:37:38 EDT
kernel-2.6.5-1.358 seem not to have this issue.
Comment 9 Ivo Sarak 2004-05-26 15:04:52 EDT
I was too quick to comment about kernel-2.6.5-1.358 - the same issue
is still present.
Comment 10 Dave Jones 2004-06-14 20:56:47 EDT
is the errata kernel any better ?
Comment 11 Ivo Sarak 2004-06-15 13:37:52 EDT
With kernel-2.6.6-1.427 my system will come up and I can even access
USB flash disk.
So, at least on this box the USB is working again.
Comment 12 Pete Zaitcev 2004-06-29 19:31:35 EDT
Marshall, if you have problems still, please open a new bug. Closing.

Note You need to log in before you can comment on or make changes to this bug.