Bug 121969 - [PATCH] Rebuilding of Digest::HMAC dies because Digest::base is missing in perl-5.8.0
[PATCH] Rebuilding of Digest::HMAC dies because Digest::base is missing in pe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 08:49 EDT by Robert Scheck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL3 U6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 13:17:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
perl-5.8.0-digest-base.patch (7.17 KB, patch)
2004-08-17 14:46 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-04-29 08:49:40 EDT
Description of problem:
--- snipp ---
+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/rfc2202....Can't locate auto/Digest/SHA1/reset.al in @INC (@INC contains: /usr/src/redhat/BUILD/Digest-HMAC-1.01/blib/lib 
/usr/src/redhat/BUILD/Digest-HMAC-1.01/blib/arch /usr/lib/perl5/5.8.0/i386-linux-thread-multi 
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi 
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl 
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi 
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0/i386-linux-thread-multi 
/usr/lib/perl5/5.8.0 . /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl 
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl 
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .) at 
/usr/src/redhat/BUILD/Digest-HMAC-1.01/blib/lib/Digest/HMAC.pm line 35
t/rfc2202....dubious
        Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED tests 8-14
        Failed 7/14 tests, 50.00% okay
Failed Test Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/rfc2202.t  255 65280    14    7  50.00%  8-14
Failed 1/1 test scripts, 0.00% okay. 7/14 subtests failed, 50.00% okay.
make: *** [test_dynamic] Error 2
Fehler: Bad exit status from /var/tmp/rpm-tmp.32099 (%build)
--- snapp ---

Version-Release number of selected component (if applicable):
perl-Digest-HMAC-1.01-(11|12)

How reproducible & Steps to Reproduce:
Everytime, caused a simple rebuild

Actual results:
I don't know what's up with "auto/Digest/SHA1/reset.al"?!

Expected results:
Rebuild including "make test" without errors :)
Comment 1 Robert Scheck 2004-08-17 14:46:16 EDT
Created attachment 102806 [details]
perl-5.8.0-digest-base.patch

I originally tracked down this bug report against Red Hat Linux 9, but before
end-of-lifetime of this product, nobody was willing to fix it :-( But this
problem also exists at (the supported) Red Hat Enterprise Linux 3... ;-)

I noticed a warning at rebuilding perl-Digest-SHA1 that Digest::base is missing
and I also noticed, that Fedora Core 2 hasn't this warning at rebuilding time -
then I found, that Fedora Core 2 delivers Digest/base.pm while Red Hat Linux 9,
Red Hat Enterprise Linux 3 and Fedore Core 1 don't. I simply copied that file
into my RHEL3 system and did a rebuild of perl-Digest-SHA1...no warning, I
installed it. After that I did a rebuild of perl-Digest-HMAC against the new
perl-Digest-SHA1...no error at "make test"!

This annoying and completely unnecessary problem (even bug!) is caused by the
internal strange build system that was used for building RHL9, RHEL3 and FC1!!

I worked out a patch for RHEL3, which I'm currently using at my critical
systems and I would be pleased to see the patch in the next perl package update
of Red Hat. My new expected result is, that I don't want to see "NOTABUG",
"WONTFIX", "DEFERRED", "WORKSFORME" or any other closing reasons of this kind,
because it IS a bug and it's caused by (a buggy build system of) Red Hat...

At current I'm also awaiting and expecting a updated perl package for RHEL3 and
FC1 with a Digest/base.pm file...
Comment 4 Jason Vas Dias 2005-11-09 23:52:57 EST
Sorry for the long delay in processing this bug.

Perhaps this is no longer a bug - a rebuild of the perl-Digest-HMAC src.rpm
succeeds WITHOUT any Digest/base.pm being installed, on a RHEL-3-U6 system.

Only the more modern versions of Digest (eg. 1.13) provide Digest::base .

The perl-5.8.0 upstream source includes Digest-1.00 .

No RHEL-3 bugs or IssueTrackers have been raised against the Digest-1.00 
shipped with perl-5.8.0, so we are not allowed to upgrade Digest in RHEL-3.

Any attempt to install any module that requires Digest::base with the perl
CPAN module e.g. with :
 # perl -MCPAN -e 'install Digest-HMAC' 
will bring in the necessary Digest >= 1.13 version which provides Digest::base . 

I will treat this as an enhancement request to provide Digest >= 1.13 in the 
RHEL-3 perl distribution instead of Digest-1.0 . As such, it is up to 
Product Management whether or not to upgrade Digest to a more recent version.
Comment 5 Robert Scheck 2005-11-12 13:17:01 EST
Right, the problem is solved now by waiting about 1.5 years from opening :-(

And yes, you're right, rebuild of perl-Digest-HMAC succeeds on RHEL3 U6, that 
is what I wanted to see. Closing with CURRENTRELEASE, thank you anyway for 
responding...

Note You need to log in before you can comment on or make changes to this bug.