Bug 121988 - exception during install right after partitioning.
exception during install right after partitioning.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 11:48 EDT by Mike Hall
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Hall 2004-04-29 11:48:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1

Description of problem:
I was installing on a laptop. I had an existing install winXP on
/dev/hda1 and FC1 with a ~905M swap partition in /dev/hda5 and ~14G
ext3 in /dev/hda6. 

I told the installer to install a fresh version (not the upgrade).

When I got to the partitioning, I clicked auto, then back, then
manual. Then I assigned "/" to the 14G partition and set both the swap
and ext3 partition to format.

Got the warning about my / not working for some systems and said continue.

Then clicked on "format"

A window with "Exception Occured" in the title with the following
traceback:

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
  self.setScreen()
File "/usr/lib/anaconda/gui.py", line 1073, in setScreen
  exec s
File "<string>", line 1, in ?
File "/usr/lib/anaconda/iw/bootloader_main_gui.py", line 1
  hbox.pack_start(button, gtk.FALSE)
  ^
SyntaxError invalid syntax


Version-Release number of selected component (if applicable):
installing from FC2-test3-DVD

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
Tried to reproduce, but did not get the error. However I did not click
auto then back then manual on the retry.

Actual Results:  Had to reboot and start the install all over.

Expected Results:  I expected the install to continue.

Additional info:

I have recently reinstalled XP so the bootloader had been overwritten
by XP during the XP install.

I did a search for other bugs and found 121798 but it looked like a
different problem from what I am experiencing.
Comment 1 Jeremy Katz 2004-04-29 18:14:59 EDT
Did you verify your media according to the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 2 Mike Hall 2004-05-03 15:53:21 EDT
Did the media check for the DVD and it passed. The version is 1.92 DVD
Comment 3 Jeremy Katz 2004-05-06 18:16:14 EDT
Can you try booting with 'linux ide=nodma'?
Comment 4 Mike Hall 2004-05-07 00:00:08 EDT
well, i was able to install the box originally. I Just didn't go into
the auto partition before backing up and going into the manual partition. 

And when I tried to reproduce it, i could not get it to crash again.
So I am not sure booting with ide=nodma will help determine anything.
If you want me to do it anyway let me know and I will.

Note You need to log in before you can comment on or make changes to this bug.