Bug 122010 - USB flash card not detected
USB flash card not detected
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 14:06 EDT by Julien Olivier
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 15:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Olivier 2004-04-29 14:06:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I have a USB flash card that isn't automatically added to /etc/fstab.

Here is what "kudzu -p" returns about it:

-
class: HD
bus: USB
detached: 0
driver: usb-storage
desc: "Alcor Micro Corp. USB Flash drive"
usbclass: 8
usbsubclass: 6
usbprotocol: 50
usbbus: 1
usblevel: 2
usbport: 1
usbdev: 5
vendorId: 058f
deviceId: 9380
usbmfr: Generic
usbprod: Mass Storage Device
-
class: HD
bus: SCSI
detached: 0
device: sda
driver: ignore
desc: "Generic Mobile Disk"
host: 1
id: 0
channel: 0
lun: 0
generic: sg0
-

I don't know why but it seems to be detected twice: once as HD/SCSI
and once as HD/USB.

In /etc/updfstab.conf.default, there is an entry in device flash that
says:

    match   hd Flash

But this doesn't work. I had to add the following for my USB device to
be detected:

    match   hd "Generic Mobile Disk"

It seems that updfstab ignores the HD/USB entry, and only reads the
description of the HD/SCSI one. Is it normal ?

Wouldn't be even smarter to simply consider that all USB/HD are flash
cards by default if their description doesn't match enything in
/etc/updfstab.conf.default ?

Thanks for your help.

Version-Release number of selected component (if applicable):
kudzu-1.1.57-1

How reproducible:
Always

Steps to Reproduce:
1.a
2.a
3.a
    

Actual Results:  a

Expected Results:  a

Additional info:

a
Comment 1 Bill Nottingham 2004-04-29 16:34:13 EDT
Not really, as there are USB attachable 'real' hard drives.
Comment 2 Julien Olivier 2004-04-29 17:57:15 EDT
Well, then I guess you should add 

match   hd "Generic Mobile Disk"

to the /etc/upfstab.conf.default file, as I had to add it myself in
the "flash device" section.
Comment 3 Bill Nottingham 2005-09-22 16:49:42 EDT
In Fedora Core 3 and later, handling of mounting of devices is done via the
'hal' component. As such, changes to updfstab are very unlikely to be made in
the future (in fact, it is no longer shipped in the kudzu tarball.)

Note You need to log in before you can comment on or make changes to this bug.