Bug 122049 - system hang on attempted 3D draw with i865G graphics
system hang on attempted 3D draw with i865G graphics
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 18:15 EDT by Ryan Tokarek
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 02:38:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of glxinfo in case it's relevant (3.26 KB, text/plain)
2004-04-29 18:17 EDT, Ryan Tokarek
no flags Details

  None (edit)
Description Ryan Tokarek 2004-04-29 18:15:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.6) Gecko/20040206 Netscape7.0/0.8

Description of problem:
On an IBM ThinkCenter (3.06GHz Hyperthreaded P4, 1GB RAM, Intel 865G
motherboard chipset), whenever I run any program in Gnome that tries
to do 3D stuff (glxgears, certain screen savers, Chromium game, etc.),
the system will hang. 

I don't know whether this is an X problem or kernel problem, but given
that I can't ssh into the machine after doing this, that I can't
ctl-alt-del, nor ctl-alt-backspace, nor ctl-alt-f1,f2,f3, etc, it
sounds like it might be kernel related. 

On test2, it would lock up graphics and keyboard/mouse, but I could
still ssh in for a clean reboot. 

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. Log into machine (into gui, in my case Gnome)
2. Run glxgears (or some other program that tries to do 3D)
3. Observe frozen system
    

Actual Results:  System hangs and needs a hard reboot. 

Expected Results:  Program runs or maybe crashes itself, but leaves
the system in a useable state.

Additional info:

I would include some debug information if I could collect it, but the
system is totally hung, and syslog doesn't get a chance to log any
relevant kernel messages to disk. 

An IBM machine info page is here:
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-51157
Comment 1 Ryan Tokarek 2004-04-29 18:17:49 EDT
Created attachment 99807 [details]
Output of glxinfo in case it's relevant
Comment 2 Scott Phipps 2004-05-02 13:27:18 EDT
I am seeing the same/ a similar problem.  My system is an amd k6-3 450
with a radeon 7500 AIW.  Anything 3d related causes the box to lock up
hard.  It also sometimes displays the same behavior during normal X
start up.  When I boot the machine or log out, and X starts, it will
lock up about every other time.
Comment 3 Arjan van de Ven 2004-05-03 06:07:48 EDT
can you try the kernel at http://people.redhat.com/arjanv/2.6
we fixed a critical bug in this code yesterday
Comment 4 Ryan Tokarek 2004-05-03 12:32:44 EDT
The new kernel didn't fix the problem. (I assume I'm just supposed to
use kernel-2.6.5-1.349.i686.rpm ) I still get a hard lockup. 
Comment 5 Scott Phipps 2004-05-03 18:00:48 EDT
Didn't help me either.
Comment 6 Scott Phipps 2004-05-04 16:04:31 EDT
Some more info in case it will help.  The same system runs fine with
FC1, no lockups with 3d.  FC2 test3 will run fine on another computer
with the same video card (ati radeon 7500 AIW), no lockups with 3d. 
Also, I get errors in the x log about not being able to load agpgart
when the system has not been shut down properly (ie it hung and I had
to hit the reset button).  If the system has been shut down properly,
I do not get these errors.
Comment 7 Ryan Tokarek 2004-05-18 18:19:07 EDT
Core 2 (Final release) (2.6.5-1.358smp) fixes the problem. 3D stuff
seems to work without killing the machine. As far as I'm concerned,
this can be resolved, but Scott Phipps had a similar problem with
different hardware as commented above. 

Thanks,
Ryan
Comment 8 Arjan van de Ven 2004-05-19 02:38:26 EDT
I will close this bug, since the intel video bug was fixed. Bugs in
other drivers should go into sepparate bugzilla's otherwise the bugs
become one big hard to understand mess. Thanks for reporting and testing.

Note You need to log in before you can comment on or make changes to this bug.