Bug 122055 - external cd-r/rw (ide) via usb will not work
Summary: external cd-r/rw (ide) via usb will not work
Status: CLOSED DUPLICATE of bug 121807
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrtools   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-29 22:55 UTC by shrek-m
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of "cdrecord -scanbus" on machine with many SCSI devices (15.70 KB, text/plain)
2004-05-01 11:48 UTC, Matt Dainty
no flags Details

Description shrek-m 2004-04-29 22:55:35 UTC
Description of problem:
under rhl x / fc1 it was no problem to burn with an external cd-r/rw
(ide) via usb

eg. under fc1:
# cdrecord -scanbus
scsibus3:    3,0,0   300)
'SAMSUNG ' 'CDRW/DVD SM-308B' 'T100' Removable CD-ROM


under fc2t3, no burner!  (not really tested under t1, t2)
`cdrecord -scanbus`
`cdrecord dev=ATAPI -scanbus`
`cdrecord ATAPI -scanbus`
...
nothing!


`cdreord dev=/dev/scd0`
`cdreord dev=ATAPI:x,x,x`
...
nothing works!


`eject cdrom1 -t`
`mount cdrom1`
is ok.

Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a27.2.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. plug in an external cd-r/rw (ide) via usb
2. try to find the burner

Actual Results:  nothing works

Expected Results:  burner should work

Additional info:

under fc1 it is ok:

# cat /proc/scsi/usb-storage-1/3
   Host scsi3: usb-storage
       Vendor: FREECOM
      Product: USB2-IDE Controller
Serial Number: 222111100FW14003DF4B42
     Protocol: Transparent SCSI
    Transport: Bulk
         GUID: 07abfc02100f014003df4b42
     Attached: Yes

Comment 1 Matt Dainty 2004-05-01 11:33:50 UTC
I've seen what looks like the same issue with a 'real' SCSI burner, it
doesn't show up in "cdrecord -scanbus", but is detected properly on
boot and is listed in /proc/scsi/scsi.

strace'ing cdrecord, it appears to be getting returned -ENXIO on
opening any of the /dev/sg* nodes, so it suggests the kernel sg driver
might be at fault here perhaps? /proc/scsi/sg/* lists no devices either.

The only device cdrecord manages to list is my IDE DVD reader which
suggests the direct ATAPI interface is behaving.

Comment 2 Matt Dainty 2004-05-01 11:48:08 UTC
Created attachment 99859 [details]
strace of "cdrecord -scanbus" on machine with many SCSI devices

Comment 3 Harald Hoyer 2004-05-06 10:37:53 UTC

*** This bug has been marked as a duplicate of 121807 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:02:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.