Bug 122070 - Received Signal 11 when installing RedHat Linux 7.3 on Compaq ProLiant 4500
Received Signal 11 when installing RedHat Linux 7.3 on Compaq ProLiant 4500
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 02:43 EDT by chan si yang
Modified: 2007-04-18 13:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 10:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chan si yang 2004-04-30 02:43:50 EDT
Description of problem:

Failure to install Redhat Linux 7.3 on a Compaq ProLiant 4500, If i 
do not specify the amount of RAM, the system will tell me that there 
is not enough RAM to install Linux. However, when i add the 
line "mem=exactmap mem=640K@0 mem=255M@1M" the installation will 
always give me a "Signal 11" and terminate the installation process 
after the line "running /sbin/loader"


Version-Release number of selected component (if applicable):
Red Hat Linux/x86 7.3 (Valhalla)

How reproducible:
Always

Steps to Reproduce:
1.Create a boot.img or bootnet.img onto a floppy and reboot from the 
diskette.
2.Type linux text expert mem=exactmap mem=640K@0 mem=255M@1M
3.Wait for installation to abort

  
Actual results:

boot: linux text expert mem=exactmap mem=640k@0 mem=255M@1M
Loading initrd.img.........
Loading vmlinuz............ ready
Uncompressing Linux... OK, booting the kernel
Linux version 2.4.18-3BOOT (bhcomplie@Stripples.devel.redhat.com)(gcc 
version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)) #1 Thu Apr 18 
06:53:28 EDT 2002
BIOS-provided physical RAM map
BIOS-88 : 0000000000000000 - 000000000009f000 (usable)
bios-88 : 0000000000100000 - 0000000001000000 (usable)
user defined physical RAM map
user: 0000000000000000 - 00000000000a0000 (usable)
user: 0000000000100000 - 0000000010000000 (usable)
On node 0 totalpages: 65536
zone(0): 4096pages
zone(1): 61440pages
zone(2): 0pages
kernel command line: initrd=initrd.img lang=devfs=nomount 
ramdisk_size=8192 vga = 788 BOOT_IMAGE=vmlinuz text expert 
mem=exactmap mem=640k@0 mem=255M@1M
No local APIC present or hardware disabled
Initializing CPU#0
Detected 99.988MHz processor.
Console: ColourVGA+ 80x25
Calibrating delay loop.. 199.47 BogoMIPS
Memory: 256000k/262144k available (1092k kernel code, 5760k reserved, 
327k data, 160k init, 0k highmem)
Dentry cache hash table entries: 32768(order:6, 262144 bytes)
Inode cache hash table entries: 16384(order:5, 131072 bytes)
Mount-cache hash table entires: 4096(order:3, 32768 bytes)
Buffer cache hash table entries: 16384(order:4, 65536 bytes)
Page-cache hash table entries: 65536(order:6, 262144bytes)
Intel Pentium with F0 0F bug- workaround enabled
CPU: Intel Pentium 75-200 stepping 05
Checking 'hlt' instruction... OK
Checking for popad bug... OK
POSIX conformance testing by UNIFIX
mtrr: V1.40(20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: none
PCI: system does not support PCI
Linux NET4.0 for Linux 2.4
Based Upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Detected PS/2 Mouse Port
pty: 256 Unix98 ptys Configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ 
SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq=4) is a 16550A
ttyS01 at 0x02f8 (irq=3) is a 16550A
block: 496 slots per queue, batch 124
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 50MHz system bus speed for PIO mode; override with 
idebus=xxide-floppy driver 0.99.newide
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
RAMDISK driver initialized: 16 RAM disks of 8192k size 1024 blocksize
loop:loaded (max 8 devices)
ide-floppy driver 0.99.newide
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb_uhci.c: $Revision: 1.275 $ time 06:55:51 Apr 18 2002
usb_uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275: USB Universal Host Controller Interface driver
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SD_DISKS=27
md: Autodetecting RAID arrays
md: autorun...
md: ... autorun DONE
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP routing cache hash table of 2048 buckets, 16kbytes
TCP:Hash tables configured (established 16384 bind 16384)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 514k freed
EXT2-fs warning : checktime reached, running e2fsck is recommended
VFS : Mounted root(ext2 filesystem)
Greetings.
Red Hat install init version 7.2 starting
mounting /proc filesystem... done
mounting /dev/pts (unix98 pty) filesystem... done
checking for NFS root filesystem... no
trying to remount root filesystem read write... done
checking for writeable /tmp... yes
running install...
running /sbin/loader
install exited abnormally -- received signal 11
sending termination signals... done
sending kill signals... done
disabling swap...
unmounting filesystems...
	/proc done
	/dev/pts done
you may safely reboot your system

Additional info:

 
Compaq ProLiant 4500

Processor 
(Pentium at 100 MHz) 
Numeric Coprocessor (Integrated 387-Compatible at 100 MHz)
Secondary Cache (512K)

Memory
256 Megabytes

Graphics Controller(s)
Integrated VGA

Slot 3 Compaq Netflex-3/E Controller
Slot 5 Cabletron Systems F70xx FDDI DNI Adapter
Slot 7 Compaq SMART-2/E Array Controller
Embedded Compaq 32-Bit Fast Wide SCSI-2/E Controller
Proc Compaq 5/100 System Processor Board
Mem Compaq Memory Expansion Board
Embedded Compaq Automatic Server Recovery (ASR)
Comment 1 Jeremy Katz 2004-05-03 10:21:43 EDT
Red Hat Linux 7.3 is no longer a supported release.  Please try with a
newer release instead.  The only things that spring to mind like this,
though, were caused by bad installation media.
Comment 2 chan si yang 2004-05-03 20:34:31 EDT
Its okay, I have managed to find a solution already... it seems that 
i had to add "nousb" to the end of the command to make it work. If 
RedHat 7.3 is not supported, then what are the versions that are?

Note You need to log in before you can comment on or make changes to this bug.