Bug 122080 - 4G/4G patch breaks syscalls with 6 arguments
Summary: 4G/4G patch breaks syscalls with 6 arguments
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ingo Molnar
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-30 09:32 UTC by Jakub Jelinek
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 17:29:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jakub Jelinek 2004-04-30 09:32:29 UTC
i686 4G/4G sysenter vDSO handles only 5 syscalls and special-cases
mmap2.  Unfortunately, this is not the only 6 argument syscall on IA-32.
E.g. fadvise64_64 has 6 arguments too, there might be others.
I wonder if it is not possible to instead just do the get_user part
in sysenter_entry before switching page tables and deal with the possible
fault in the trap handler.

Comment 1 Jakub Jelinek 2004-04-30 09:33:44 UTC
Of course I meant "handles only 5 argument syscalls"...

Comment 2 Warren Togami 2005-05-20 09:37:53 UTC
Is this a issue for any non-i686 arch?
Since FC4 ships without 4G/4G, shouldn't this be FC5 instead of FC4 target?

Comment 3 Ingo Molnar 2005-09-15 17:29:27 UTC
closing this bug - it seems glibc is now working this around by always doing
int80 for fadvise64_64.


Note You need to log in before you can comment on or make changes to this bug.