Bug 122089 - SIS900 network does not get found
SIS900 network does not get found
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 121823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 07:47 EDT by Need Real Name
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 01:25:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-04-30 07:47:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
On my box with a sis900 built-in network card the message "device eth0
- not found - delaying initialiation" appears when I run ifup eth0

System-config-network-devices shows the interface (including name)

The module is loaded as well

This worked with no problems in test2 and previous

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to test3
2.
3.
    

Actual Results:  no network

Additional info:
Comment 1 Need Real Name 2004-05-06 05:39:21 EDT
*** Bug 121823 has been marked as a duplicate of this bug. ***
Comment 2 Need Real Name 2004-05-10 07:55:22 EDT
Bug still present in 2.6.5-358 - network works with vanilla 2.5.3 from
test2
Comment 3 Need Real Name 2004-05-12 07:16:47 EDT
Problem is also present in vanilla 2.6.6

This patch I got from lkml (Aristeu Filho) works

--- linux-2.6.5/drivers/net/sis900.c.old        2004-05-11
21:50:35.000000000 -0300
+++ linux-2.6.5/drivers/net/sis900.c    2004-05-11 21:51:38.000000000
-0300
@@ -260,7 +260,8 @@ static int __devinit sis630e_get_mac_add
        u8 reg;
        int i;
 
-       if ((isa_bridge = pci_find_device(0x1039, 0x0008, isa_bridge))
== NULL) {
+       if ((isa_bridge = pci_find_device(0x1039, 0x0008, isa_bridge))
== NULL &&
+               (isa_bridge = pci_find_device(0x1039, 0x0018,
isa_bridge)) == NULL) {
                printk("%s: Can not find ISA bridge\n", net_dev->name);
                return 0;
        }
Comment 4 Rik Burt 2004-05-19 11:53:24 EDT
I am also having this problem.

From /var/log/messages

May  7 05:45:44 localhost kernel: sis900.c: v1.08.07 11/02/2003
May  7 05:45:44 localhost kernel: PCI: Found IRQ 10 for device
0000:00:01.1
May  7 05:45:44 localhost kernel: PCI: Sharing IRQ 10 with 0000:00:0f.1
May  7 05:45:44 localhost kernel: eth0: Can not find ISA bridge
Comment 5 Dave Jones 2004-06-14 21:03:44 EDT
this should be fixed in the errata kernel. please confirm?
Comment 6 Dave Jones 2004-12-07 01:25:53 EST
6 months with no comment - closing

Note You need to log in before you can comment on or make changes to this bug.