Bug 122099 - Bad: usb flash_disk timeout
Bad: usb flash_disk timeout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 10:40 EDT by Ivo Panacek
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 20:07:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
*.debug log (20.10 KB, text/plain)
2004-04-30 10:41 EDT, Ivo Panacek
no flags Details
*.debug log with same behavior with UNPATCHED kernel 2.6.5-1.327 (22.01 KB, text/plain)
2004-04-30 10:57 EDT, Ivo Panacek
no flags Details

  None (edit)
Description Ivo Panacek 2004-04-30 10:40:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
On fresh (!) installation of Fedora Core 2 test 3,
kernel 2.6.5-1.327
after successfull mounting of usb 1 flash disk
writing fails after some time.
I made ext2fs on it (partition /dev/sda1) - ok
mounted - ok
writing data - fails after some time.
I have found discussion on linux-usb-devel list
with patch attached:

http://marc.theaimsgroup.com/?l=linux-usb-devel&m=108238832020721&q=raw

I tested it with similar result, just more data
are written to flash disk before it fails

(it works on this hardware with FC1 and 2.4 kernel)

I will include debugging output in attachment

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install FC2test3
2. mount usb flash_disk
3. try to write some data (more than 10MB)
    

Actual Results:   kernel: usb 1-1: control timeout on ep0in

Additional info:
Comment 1 Ivo Panacek 2004-04-30 10:41:50 EDT
Created attachment 99823 [details]
*.debug log
Comment 2 Ivo Panacek 2004-04-30 10:57:08 EDT
Created attachment 99825 [details]
*.debug log with same behavior with UNPATCHED kernel 2.6.5-1.327
Comment 3 Dave Jones 2004-06-14 21:04:56 EDT
any improvement with the errata kernel ?
Comment 4 Ivo Panacek 2004-06-15 04:15:34 EDT
Yes, current kernels work ok, for sure since 2.6.5-1.358.

Note You need to log in before you can comment on or make changes to this bug.