Bug 122110 - Matrox Mystique does not display the screen properly
Matrox Mystique does not display the screen properly
Status: CLOSED DUPLICATE of bug 124028
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 12:00 EDT by Stefan Hoelldampf
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda screenshot 0000 (161.48 KB, image/png)
2004-04-30 12:02 EDT, Stefan Hoelldampf
no flags Details
anaconda screenshot 0001 (20.55 KB, image/png)
2004-04-30 12:05 EDT, Stefan Hoelldampf
no flags Details
anaconda screenshot 0002 (55.64 KB, image/png)
2004-04-30 12:06 EDT, Stefan Hoelldampf
no flags Details

  None (edit)
Description Stefan Hoelldampf 2004-04-30 12:00:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
Since FC2-test2, X cannot display the screen correctly. FC2-test1 is
the last version without such problems (due to XFree86 instead of
xorg-x11?).

During the installation:
- Images are placed wrong on the screen.
- Parts of the text are not displayed.
- The description of buttons is only shown if you move the mouse
pointer over it.
- ...

When the installation is complete:
Konqueror, Nautilus, Mozilla, nearly all programs have problems
scrolling content (filelists, webpages).
It was verd hard to use Mozilla for writing this bugreport.


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5


How reproducible:
Always


Steps to Reproduce:
1. Start the installation
    

Additional info:
- Mainboard: ECS Elitegroup K7S5A
- Graphic Card: Matrox Mystique ("Matrox Graphics, Inc. MGA 1064SG
[Mystique] (rev 03)")
Comment 1 Stefan Hoelldampf 2004-04-30 12:02:47 EDT
Created attachment 99826 [details]
anaconda screenshot 0000
Comment 2 Stefan Hoelldampf 2004-04-30 12:05:02 EDT
Created attachment 99827 [details]
anaconda screenshot 0001
Comment 3 Stefan Hoelldampf 2004-04-30 12:06:57 EDT
Created attachment 99828 [details]
anaconda screenshot 0002

The left box was scrolled down and then up again using the mouse.
Comment 4 Stefan Hoelldampf 2004-05-09 15:03:39 EDT
Adding the line
        Option      "NoAccel" "yes"
to the Device-Section in /etc/X11/xorg.conf "fixes" the problem, but
the graphic output is very slow as expected.

I have found something related in XFree86`s Bugzilla but I don't
really know which fixes/patches described there have been applied to
xorg-x11.

- http://bugzilla.xfree86.org/show_bug.cgi?id=1313
  "Graphics corruption on Matrox Mystique (mga1064sg)"
- http://bugzilla.xfree86.org/show_bug.cgi?id=1243
  "Blitting on Mystique-220 broken"
- http://bugzilla.xfree86.org/show_bug.cgi?id=85
  "unrecoverable freeze with mga mystique, unless NoAccel is specified"
Comment 5 Mike A. Harris 2004-07-05 19:19:54 EDT

*** This bug has been marked as a duplicate of 124028 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.