Bug 122150 - Crash when save as Word format (.doc)
Crash when save as Word format (.doc)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 18:03 EDT by Efthym
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-01 15:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
. (380.73 KB, application/octet-stream)
2004-05-01 04:56 EDT, Efthym
no flags Details

  None (edit)
Description Efthym 2004-04-30 18:03:40 EDT
From Bugzilla Helper:
User-Agent: Opera/7.50 (X11; Linux i686; U)  [en]

Description of problem:
When I open .sxw file in Writer and then try to Save As a Word .doc 
file, the program crashes

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4

How reproducible:
Always

Steps to Reproduce:
1.Open OpenOffice.org Writer
2.Open .sxw file
3.File->Save As->Microsoft Word 97/2000/XP (.doc)
4.Press Save

Actual Results:  OpenOffice crashes. Messages Popsup "An 
unrecoverable error has occured. All modified files have been saved 
and can probably be recovered at program restart".

Expected Results:  Save file in .doc and continue working

Additional info:

Backtrace was generated from '/usr/lib/ooo-1.1/program/soffice.bin'

(no debugging symbols found)...Using host libthread_db library 
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...[Thread 
debugging using libthread_db enabled]
[New Thread -1207135424 (LWP 2138)]
[New Thread 1116457904 (LWP 2166)]
[Thread debugging using libthread_db enabled]
[New Thread -1207135424 (LWP 2138)]
[New Thread 1116457904 (LWP 2166)]
[Thread debugging using libthread_db enabled]
[New Thread -1207135424 (LWP 2138)]
[New Thread 1116457904 (LWP 2166)]
[New Thread 1093970864 (LWP 2161)]
[New Thread 1083481008 (LWP 2158)]
[New Thread 63347632 (LWP 2157)]
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...0x00c0c41a 
in ?? ()
#0  0x00c0c41a in ?? ()
#1  0xbff23f84 in ?? ()

Thread 5 (Thread 63347632 (LWP 2157)):
#0  0x00c0c41a in ?? ()
No symbol table info available.
#1  0x03c69028 in ?? ()
No symbol table info available.
#2  0x016b71ec in ?? () from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#3  0x03c69010 in ?? ()
No symbol table info available.
#4  0x003cb1c8 in accept () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x015252c6 in osl_acceptPipe () from /usr/lib/ooo-1.
1/program/libsal.so.3
No symbol table info available.
#0  0x00c0c41a in ?? ()
Comment 1 mark 2004-04-30 19:49:00 EDT
there's more going on here than i think you realize... i can not
duplicate this with FC2 test3 on my i686. i can open .sxw files and
then save as .doc files without generating an error or exception.

i'm guessing that something else is causing this (somehow). perhaps,
its my kernel that i'm using that is preventing this from happening.
perhaps, try a different kernel? is selinux disabled or enabled? (i'm
running disabled but i haven't yet passed selinux=0 to the kernel..
i'll do that on the next restart) well, hope this helps...

here's some more info on my setup:

[root@markf78 home]# rpm -q openoffice.org
openoffice.org-1.1.1-4

[root@markf78 home]# rpm -q kernel
kernel-2.6.3-2.1.253.2.1

[root@markf78 home]# more /etc/sysconfig/selinux
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcinfg - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - No SELinux policy is loaded.
SELINUX=disabled

[root@markf78 home]# rpm -q policy
policy-1.11.2-13
Comment 2 Efthym 2004-04-30 20:19:11 EDT
I just tried again with enforce=0, same thing happens.
check messages and nothing shows up there. I'll try a different 
kernel later on (i think i still have 2.6.4 ) and let you know. 
Anything else i should check ?

[root@Purgatory root]# cat /selinux/enforce
0
[root@Purgatory root]# rpm -q openoffice.org policy
openoffice.org-1.1.1-4
policy-1.11.2-18
[root@Purgatory root]# uname -a
Linux Purgatory.bakouria.org 2.6.5-1.327custom #2 Mon Apr 26 20:17:24 
EDT 2004 i686 i686 i386 GNU/Linux
Comment 3 Efthym 2004-05-01 01:20:22 EDT
tried with 2.6.4-1.298 and 2.6.5-1.327 (both stock). Same problem.
Comment 4 Marius Andreiana 2004-05-01 04:21:18 EDT
Does this happens with a new document?
e.g. open writer, write "abc", save as .doc.

If not, attach your sxw document.
Comment 5 Efthym 2004-05-01 04:56:09 EDT
Created attachment 99858 [details]
.
Comment 6 Efthym 2004-05-01 05:00:53 EDT
You are right, creating a new one doesn't cause a problem. Sorry for 
not trying this first and for the false alarm ;)
This file i was able to convert to .doc like a month ago. trying it 
again now causes the error (haven't changed anything since then).
Comment 7 Marius Andreiana 2004-05-01 06:04:57 EDT
works fine for me on FC1, ooo 1.1.0.

Please report this upstream:
http://www.openoffice.org/issues/enter_bug.cgi
for version 1.1.1 and attach the document.

Close this bug as resolved UPSTREAM.
Comment 8 Efthym 2004-05-01 15:55:34 EDT
Submitted upstream.

http://www.openoffice.org/issues/show_bug.cgi?id=28602

Thanks to all for your help

Note You need to log in before you can comment on or make changes to this bug.