Bug 122153 - upgrade from FC1/x86_64 crashes after installing all packages
upgrade from FC1/x86_64 crashes after installing all packages
Status: CLOSED DUPLICATE of bug 118300
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 18:45 EDT by Steven Pritchard
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump from crash (819.25 KB, text/plain)
2004-04-30 18:46 EDT, Steven Pritchard
no flags Details

  None (edit)
Description Steven Pritchard 2004-04-30 18:45:05 EDT
I just tried upgrading a FC1/x86_64 box to FC2 test3 via a HTTP
install.  It looks like all packages installed, but the installer
crashed with the following error:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1044, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/bootloader.py", line 131, in writeBootloader
    kernelList.append((kernelLabel, kernelLongLabel, version))
UnboundLocalError: local variable 'kernelLabel' referenced before
assignment
Comment 1 Steven Pritchard 2004-04-30 18:46:56 EDT
Created attachment 99851 [details]
Anaconda dump from crash
Comment 2 Alan Cox 2004-05-02 17:18:18 EDT
Saw the same on a dual opteron via CD upgrade from FC2test2 to test3
Comment 3 Jeremy Katz 2004-05-03 10:36:18 EDT
Which boot loader option did you select (upgrade existing, install new
or do nothing)?
Comment 4 Alan Cox 2004-05-03 10:51:08 EDT
upgrade existing from FC2test2 in my case. A reinstall worked
Comment 5 Steven Pritchard 2004-05-03 18:18:47 EDT
Almost certainly "upgrade existing", as that's what I always do, but I
honestly don't remember.
Comment 6 Jeremy Katz 2004-05-06 18:12:11 EDT

*** This bug has been marked as a duplicate of 118300 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.