Bug 122162 - (PATCH)No bind mounts without NFS export
(PATCH)No bind mounts without NFS export
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 00:59 EDT by Jason Tibbitts
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 14:25:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix get_best_mount to not call rpc_ping for local mounts (447 bytes, patch)
2004-05-01 01:01 EDT, Jason Tibbitts
no flags Details | Diff

  None (edit)
Description Jason Tibbitts 2004-05-01 00:59:11 EDT
Running autofs-4.1.2-2 from FC2T3 I found that I cannot access a mount
map entry like:

blah localhost:/path/blah

unless the NFS server is running and /path/blah is exported.  This
worked under FC1 and as far back as I can recall autofs being available.

I reported this upstream and it was confirmed as a bug.  The attached
patch was sent to me by raven at themaw.net; I tweaked the autofs spec
file to apply the patch, rebuilt the package and installed it.  My
problem is solved.

I'll leave it to you to decide whether this merits fixing for FC2; I
can always use my local packages.
Comment 1 Jason Tibbitts 2004-05-01 01:01:53 EDT
Created attachment 99854 [details]
Patch to fix get_best_mount to not call rpc_ping for local mounts
Comment 2 Jeff Moyer 2004-05-03 11:18:06 EDT
I've posted an updated package on my people page for testing.  It is
the autofs maintainers version of this fix, along with a fix for
multi-mounts.  Would you mind trying it?  The version is 4.1.2-4.  If
enough people test and report success, I will move this into rawhide.

Thanks!

Jeff
Comment 3 Jeff Moyer 2004-05-03 11:18:36 EDT
Sorry, forgot to post a pointer to the package:

http://people.redhat.com/~jmoyer/
Comment 4 Jason Tibbitts 2004-05-19 17:51:54 EDT
I have verified that stock FC2 still has this problem, but that the
4.1.2-6 package from the above URL fixes things.
Comment 5 Jason Tibbitts 2004-08-27 14:25:47 EDT
This is fixed in FC3t1; let's see if I can close the bug.

Note You need to log in before you can comment on or make changes to this bug.