Bug 122178 - gnome-cd-properties crashes on start
gnome-cd-properties crashes on start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: magicdev (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
David Lawrence
:
: 122177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 11:36 EDT by Manuel Moreno
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 14:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Moreno 2004-05-01 11:36:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040422

Description of problem:
gnome-cd-properties crashes on startup.

when started from command line...

(gnome-cd-properties:23017): GdkPixbuf-CRITICAL **: file
gdk-pixbuf-io.c: line 761 (gdk_pixbuf_new_from_file): assertion
`filename != NULL' failed

------------------------------------
Backtrace was generated from '/usr/bin/gnome-cd-properties'

(no debugging symbols found)...Using host libthread_db library
"/lib64/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 182895761120 (LWP 23017)]
0x0000003e14c0be26 in waitpid () from /lib64/tls/libpthread.so.0
#0  0x0000003e14c0be26 in waitpid () from /lib64/tls/libpthread.so.0
#1  0x0000003e1c255182 in libgnomeui_module_info_get ()
   from /usr/lib64/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x0000003e186f0c6b in gtk_window_get_icon ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#4  0x0000003e186f0e36 in gtk_window_set_default_icon_from_file ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#5  0x0000000000402841 in init_cd_capplet ()
#6  0x0000000000402d0e in main ()

Thread 1 (Thread 182895761120 (LWP 23017)):
#0  0x0000003e14c0be26 in waitpid () from /lib64/tls/libpthread.so.0
No symbol table info available.
#1  0x0000003e1c255182 in libgnomeui_module_info_get ()
   from /usr/lib64/libgnomeui-2.so.0
No symbol table info available.
#2  <signal handler called>
No symbol table info available.
#3  0x0000003e186f0c6b in gtk_window_get_icon ()
   from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#4  0x0000003e186f0e36 in gtk_window_set_default_icon_from_file ()
   from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#5  0x0000000000402841 in init_cd_capplet ()
No symbol table info available.
#6  0x0000000000402d0e in main ()
No symbol table info available.
#0  0x0000003e14c0be26 in waitpid () from /lib64/tls/libpthread.so.0


Version-Release number of selected component (if applicable):
magicdev-1.1.6-1

How reproducible:
Always

Steps to Reproduce:
1.
bash# gnome-cd-properties
    

Actual Results:  crash

Expected Results:  dialog for changing preferences on mounting cd's,  etc.

Additional info:
Comment 1 Alan Cox 2004-05-02 17:58:23 EDT
Works fine for me on both 32 and 64bit. Standardish box with one CD
driver. Anything unusual in your setup ?
Comment 2 Alan Cox 2004-05-02 17:58:53 EDT
*** Bug 122177 has been marked as a duplicate of this bug. ***
Comment 3 Manuel Moreno 2004-05-03 05:39:35 EDT
I have one DVD+/-RW unit in /dev/hdb and one CD-RW in /dev/hdd

------------------------------------------------------------
hdb: ATAPI 32X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 40X CD-ROM CD-R/RW CD-MRW drive, 2048kB Cache, UDMA(33)
gnome-cd-proper[3108]: segfault at 0000000000000008 rip
0000003e186f0c6b rsp 0000007fbffff5e0 error 4
------------------------------------------------------------
Kernel is Arjan's 2.6.5-1.347 recompiled (to add k8 powercontrol ...)
and glibc is glibc-2.3.3-20


I am using GNOME despite being bitten by the nautilus problem (I have
to change /etc/fstab or else nautilus crashes on start)
Comment 4 Manuel Moreno 2004-05-03 05:45:37 EDT
Well while I was at it I heard a little bell from the back of my head:
I was using a nonstandard theme (Wasp) from the extended themes
package... When I changed to 'Bluecurve' gnome-cd-properties returned
to work as usual! :-)

So, who is to blame?



P.S. This new GNOME is fragile as crystal!
Comment 5 John (J5) Palmieri 2004-08-25 14:14:35 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.