Bug 122180 - vncserver seems to kill font server
vncserver seems to kill font server
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 12:12 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-03 14:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-05-01 12:12:15 EDT
Description of problem:

I boot into level 3 (command line) and then manually startx.

If I startx before vncserver, then I get good fonts in the Gnome desktop.

If I start vncserver first, I then get (ugly) default fonts in the
desktopmenus.

See listing of vncserver log below. Probably something obvious (but
not to me).

Version-Release number of selected component (if applicable):
  Xvnc version 4.0b4

How reproducible:
 Always

Steps to Reproduce:
1.boot to command line
2.startx
3.observe Gnome menu font style (as set in Preferences->font)
  
4.reboot to command line
5.vncserver
6.startx
7.observe Gnome menu font style (default - ugly)
Actual results:

  Fontserver (?) seems to be killed or intercepted by vnc

Expected results:

  Fonts in vncserver should be the same as in Gnome desktop and
desktop fonts should not depend on startup order of vncserver/desktop


Additional info:

[user1@hoho2 user1]$ more .vnc/hoho2.chidig.com:1.log
 
Xvnc version 4.0b4 - built Apr 14 2004 12:42:18
Underlying X server release 40300000, The XFree86 Project, Inc
 
 
Sat May  1 10:59:08 2004
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
SESSION_MANAGER=local/hoho2.chidig.com:/tmp/.ICE-unix/3183
esd: Esound sound daemon already running or stale UNIX socket
/tmp/.esd/socket
This socket already exists indicating esd is already running.
Exiting...
Fontconfig warning: line 273: invalid edit binding "same"
Fontconfig warning: line 285: invalid edit binding "same"
Window manager warning: Log level 32: could not find XKB extension.
Fontconfig warning: line 273: invalid edit binding "same"
Fontconfig warning: line 285: invalid edit binding "same"
Fontconfig warning: line 273: invalid edit binding "same"
Fontconfig warning: line 285: invalid edit binding "same"
/usr/share/rhn/rhn_applet/rhn_applet.py:362: DeprecationWarning:
integer argument expected, got float
  self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 *
ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)
                                                                     
          
(gnome-panel:3214): Gtk-WARNING **: Ignoring the separator setting
Fontconfig warning: line 273: invalid edit binding "same"
Fontconfig warning: line 285: invalid edit binding "same"
[user1@hoho2 user1]$
Comment 1 Tim Waugh 2004-05-07 04:50:03 EDT
I don't see those errors here.  Sounds like your fonts.conf file is
different to mine.  What does 'rpm -V fontconfig' say for you?

# rpm -V fontconfig
S.?......   /usr/bin/fc-cache
S.?......   /usr/bin/fc-list
S.?......   /usr/lib/libfontconfig.so.1.0.4
# rpm -q fontconfig
fontconfig-2.2.1-10
Comment 2 Bob Gustafson 2004-05-08 04:46:40 EDT
This is now from an updated FC2(Test3) running kernel 351

  [root@hoho2 user1]# cat /proc/version
  Linux version 2.6.5-1.351smp (bhcompile@perf87.perf.redhat.com)
  (gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 SMP
  Wed May 5 10:55:10 EDT 2004
  [root@hoho2 user1]#


From a Gnome terminal window accessed through VNC
 
  [root@hoho2 user1]# rpm -V fontconfig
  S.?......   /usr/bin/fc-cache
  S.?......   /usr/lib/libfontconfig.so.1.0.4
  [user1@hoho2 user1]$ rpm -q fontconfig
  fontconfig-2.2.1-10
  [user1@hoho2 user1]$
 
  [root@hoho2 user1]# date
  Fri May  7 19:20:19 CDT 2004
  [root@hoho2 user1]#
 
The settings in Gnome Preferences are:
Preferences -> Font
Bitstream Vera Sans 12

The fonts visible in the Gnome menu are smaller and thinner than the
Bitstream Vera Sans 12

This is the ps display of vnc

  [root@hoho2 user1]# ps ax | grep vnc
  23226 pts/1    S      0:26 Xvnc :1 -desktop hoho2.chidig.com 1  
  (user1) -httpd /usr/share/vnc/classes -auth /home/user1/.Xauthority 
  -geometry 1024x768 -depth 16 -rfbwait 30000 -rfbauth
  /home/user1/.vnc/passwd -rfbport 5901 -pn
  23487 pts/5    S      0:00 grep vnc
  [root@hoho2 user1]#

When I go back to the console window (running Gnome as user1) and log
out and then log in again (startx), then I also see the small thin
font in the Gnome menu list entries.

Let me know what else you would like to see. I can reboot and paste on
the dmesg?
Comment 3 Bob Gustafson 2004-05-09 18:29:56 EDT
A different problem I had was because the yum/rpm process did not
replace my config file - even though a config file was in the rpm
package. I guess this is fairly common. An alternative is to rename
the existing config file and then load in the rpm config file. Some
packages do this, some don't.

I can do this if you wish - rename my font.conf file and then reload
the package ( --force) and see what happens then.

Let me know the name of the config file(s) and the name of the
package(s) to rename and re-rpm.
Comment 4 Bob Gustafson 2004-05-10 11:43:54 EDT
OK, I renamed the /etc/fonts directory and then reloaded fontconfig
from the latest rpm

  rpm -i --force fontconfig-2.2.1-10.i386.rpm

The result is:
  [root@hoho2 user1]# ls -ld /etc/fonts*
  drwxr-xr-x  2 root root 4096 May  9 23:07 /etc/fonts
  drwxr-xr-x  2 root root 4096 Apr 20 09:40 /etc/fontsx

  [root@hoho2 user1]# ls -l /etc/fonts
  total 40
  -rw-r--r--  1 root root 15303 Apr 19 12:18 fonts.conf
  -rw-r--r--  1 root root  5840 Apr 19 12:18 fonts.dtd
  -rw-r--r--  1 root root   350 Apr 19 12:18 local.conf
  [root@hoho2 user1]#

I still have the same problem/symptom.

The 'first' startx or vncserver command gets a Gnome window where the
Gnome menu is the requested larger fatter font.

The 'second' startx or vncserver command gets a Gnome window where the
Gnome menu is small and thin - probably a default font from somewhere.


Then I did the rpm -V checks as you suggested

  [root@hoho2 user1]# setenforce 0
  [root@hoho2 user1]# rpm -V fontconfig

Hmm, not the same as your font.conf result..

  [root@hoho2 user1]# rpm -q fontconfig
  fontconfig-2.2.1-10


More info

  [root@hoho2 user1]# date
  Mon May 10 10:27:22 CDT 2004
  [root@hoho2 user1]# cat /proc/version
  Linux version 2.6.5-1.358smp (bhcompile@bugs.build.redhat.com) (gcc 
  version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 SMP Sat May 8 
  09:25:36 EDT 2004
  [root@hoho2 user1]#

Comment 5 Bob Gustafson 2004-05-13 02:13:09 EDT
I thought I may have had the solution to the problem:

I clicked on Gnome menu -> Graphics -> GIMP Image Editor

At the end of the launch process, I saw a notice window that said GIMP
needed at least Fontconfig 2.2.0 and that it was seeing a library with
a previous version:

  /usr/X11R6/lib/libfontconfig.so.1 
  /usr/X11R6/lib/libfontconfig.so.1.0.4

The notice window recommended that these old libraries be deleted.

Naturally, I thought that this was probably the reason for my problem
with vncserver having the default font when it was started up after
'startx'. I deleted the version 1 libraries in that directory and
rebooted and then tried GIMP.

GIMP launched successfully - no notice window.

However, I still have the default font problem with vncserver when it
is launched after startx.

[I do have other libraries in that same directory with old and newer
versions - is this a problem?]
Comment 6 Bob Gustafson 2004-05-24 22:52:36 EDT
I still have the same problem, even after doing a clean install of FC2
and  'yum --exclude=ppp update \*'  With devel updates included in sources

----

The symptoms are quite precise.

I did a chkconfig to make vncserver start at run levels 3 and 5.

I have /etc/inittab set so I boot into run level 3 (command line)

Then I log in and do a 'startx' to get Gnome running on the console.

At this point, my console Gnome is using some thin default font and
the vnc session viewed from another computer - has the nice big thick
font.  (This is because the vncserver was started 'first')

Then, in a Gnome terminal window, I stop the vncserver

  [root@hoho2 user1]# cd /etc/init.d
  [root@hoho2 init.d]# ./vncserver stop
  Shutting down VNC server: 1:user1                          [  OK  ]

At this moment, without me doing anything else, the menu titles at the
top of the Gnome terminal window become larger and fatten up.

It is almost as if the window had been polling the font server - and
could not 'get in' because it was blocked by somebody who got there
first - vncserver. When vncserver was killed, the polling succeeded
and the fonts on my Gnome terminal window were refreshed with the
desired fonts.

What is really happening?
Comment 7 Bob Gustafson 2004-05-26 23:01:00 EDT
This is the log file for vnc after it has been stopped and then
started up (cd /etc/init.d; ./vncserver start)

Running with selinux=1 enforce=0  (just warnings)

There are a lot of odd looking messages..

---------
[root@hoho2 .vnc]# more hoho2.chidig.com:1.log
 
Xvnc version 4.0b5 - built May 20 2004 10:59:48
Underlying X server release 40300000, The XFree86 Project, Inc
 
 
Wed May 26 21:53:13 2004
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
error opening security policy file
/usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
removing from list!
cat: /root/.xauth27GLLT: Permission denied
warning: /etc/X11/xinit/xinitrc.d/xinput does not end in .sh
extension, ignoringwarning: /etc/X11/xinit/xinitrc.d/xmbind does not
end in .sh extension, ignoring_IceTransmkdir: Owner of /tmp/.ICE-unix
should be set to root
SESSION_MANAGER=local/hoho2.chidig.com:/tmp/.ICE-unix/4578
Window manager warning: Log level 32: could not find XKB extension.
/usr/share/rhn/rhn_applet/rhn_applet.py:362: DeprecationWarning:
integer argument expected, got float
  self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 *
ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)
[root@hoho2 .vnc]#
[root@hoho2 .vnc]#

Comment 8 Bob Gustafson 2004-05-28 10:41:08 EDT
The vncserver doesn't start for me now ??

Transcript of my flailing around might provide some clues - see below

[root@hoho2 init.d]# ps ax | grep vnc
 7604 pts/1    S+     0:00 grep vnc

[root@hoho2 user1]# cd /etc/init.d
[root@hoho2 init.d]# ./vncserver start
Starting VNC server: 1:user1
Warning: hoho2.chidig.com:1 is taken because of /tmp/.X1-lock
Remove this file if there is no X server hoho2.chidig.com:1
A VNC server is already running as :1
                                                           [FAILED]
[root@hoho2 init.d]# rm /tmp/.X1-lock
rm: remove regular file `/tmp/.X1-lock'? y

[root@hoho2 init.d]# ./vncserver start
Starting VNC server: 1:user1
Warning: hoho2.chidig.com:1 is taken because of /tmp/.X11-unix/X1
Remove this file if there is no X server hoho2.chidig.com:1
A VNC server is already running as :1
                                                           [FAILED]
[root@hoho2 init.d]# ps ax | grep vnc
 7604 pts/1    S+     0:00 grep vnc

[root@hoho2 init.d]# ps ax | grep X
 7266 tty1     S+     0:00 /bin/sh /usr/X11R6/bin/startx
 7277 tty1     S+     0:00 xinit /etc/X11/xinit/xinitrc --
 7278 ?        S      0:06 X :0
 7324 ?        Ss     0:00 ssh-agent /etc/X11/xinit/Xclients
 7637 pts/1    S+     0:00 grep X

[root@hoho2 init.d]# cd /home/user1
[root@hoho2 user1]# cd .vnc
[root@hoho2 .vnc]# ls -l
total 40
-rw-r--r--  1 user1 user1 10335 May 27 21:46 hoho2.chidig.com:1.log
-rw-r--r--  1 user1 user1     5 May 27 21:46 hoho2.chidig.com:1.pid
-rw-------  1 user1 user1     8 May 23 21:37 passwd
-rwxr-xr-x  1 user1 user1   382 May 23 22:00 xstartup

Note that dates and times of above files are ...old... not today
Will blow away

[root@hoho2 .vnc]# cd ..
[root@hoho2 user1]# rm -rf .vnc
[root@hoho2 user1]#
[root@hoho2 user1]# ps ax | grep vnc
 7642 pts/1    S+     0:00 grep vnc
[root@hoho2 user1]# ls /tmp/.X*
/tmp/.X0-lock
 
/tmp/.X11-unix:
X0  X1
[root@hoho2 user1]# cd /etc/init.d
[root@hoho2 init.d]# ./vncserver start
Starting VNC server: 1:user1                               [FAILED]

[root@hoho2 init.d]# cd /home/user1/.vnc
bash: cd: /home/user1/.vnc: No such file or directory

[root@hoho2 init.d]# tail /var/log/messages
May 28 09:22:07 hoho2 su(pam_unix)[7595]: session opened for user
user1 by user1(uid=0)
May 28 09:22:07 hoho2 su:
May 28 09:22:07 hoho2 su: Warning: hoho2.chidig.com:1 is taken because
of /tmp/.X11-unix/X1
May 28 09:22:07 hoho2 su(pam_unix)[7595]: session closed for user user1
May 28 09:22:07 hoho2 su: Remove this file if there is no X server
hoho2.chidig.com:1
May 28 09:22:07 hoho2 su: A VNC server is already running as :1
May 28 09:22:07 hoho2 vncserver: vncserver start failed
May 28 09:28:22 hoho2 su(pam_unix)[7648]: session opened for user
user1 by user1(uid=0)
May 28 09:28:22 hoho2 su(pam_unix)[7648]: session closed for user user1
May 28 09:28:22 hoho2 vncserver: vncserver start failed

[root@hoho2 init.d]# rm /tmp/.X11-unix/X1
rm: remove socket `/tmp/.X11-unix/X1'? y

[root@hoho2 init.d]# ./vncserver start
Starting VNC server: 1:user1                               [FAILED]
[root@hoho2 init.d]# tail -6 /var/log/messages
May 28 09:28:22 hoho2 su(pam_unix)[7648]: session opened for user
user1 by user1(uid=0)
May 28 09:28:22 hoho2 su(pam_unix)[7648]: session closed for user user1
May 28 09:28:22 hoho2 vncserver: vncserver start failed
May 28 09:31:11 hoho2 su(pam_unix)[7663]: session opened for user
user1 by user1(uid=0)
May 28 09:31:11 hoho2 su(pam_unix)[7663]: session closed for user user1
May 28 09:31:11 hoho2 vncserver: vncserver start failed
[root@hoho2 init.d]# ls -l /home/user1/.vnc
ls: /home/user1/.vnc: No such file or directory
[root@hoho2 init.d]#

--- try again --[root@hoho2 init.d]# ls /tmp/.X*
/tmp/.X0-lock
 
/tmp/.X11-unix:
X0

[root@hoho2 init.d]# ./vncserver start
Starting VNC server: 1:user1                               [FAILED]

[root@hoho2 init.d]# ls -l /home/user1/.vnc
ls: /home/user1/.vnc: No such file or directory
[root@hoho2 init.d]#




Comment 9 Bob Gustafson 2004-05-28 11:04:16 EDT
Remove and replace - no go

[root@hoho2 root]# yum remove vnc
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - Development Tree
Server: Fedora Core 2 - i386 - Released Updates
Server: Fedora Core 2 - i386 - Unreleased Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[erase: vnc 4.0-1.beta5.2.i386]
Is this ok [y/N]: y
Downloading Packages
Running test transaction:
Test transaction complete, Success!
Erasing: vnc 1/2
Erasing: vnc 2/2
Erased:  vnc 4.0-1.beta5.2.i386
Transaction(s) Complete

[root@hoho2 root]# yum install vnc
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - Development Tree
Server: Fedora Core 2 - i386 - Released Updates
Server: Fedora Core 2 - i386 - Unreleased Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[install: vnc 4.0-1.beta5.3.i386]
Is this ok [y/N]: y
Downloading Packages
Getting vnc-4.0-1.beta5.3.i386.rpm
vnc-4.0-1.beta5.3.i386.rp 100% |=========================| 159 kB    00:00
Running test transaction:
Test transaction complete, Success!
vnc 100 % done 1/1
Installed:  vnc 4.0-1.beta5.3.i386
Transaction(s) Complete

[root@hoho2 root]# cd /etc/init.d
[root@hoho2 init.d]# ls -l /home/user1/.vnc
ls: /home/user1/.vnc: No such file or directory

[root@hoho2 init.d]# ./vncserver start
Starting VNC server: 1:user1                               [FAILED]
[root@hoho2 init.d]#

Comment 10 Tim Waugh 2004-05-28 11:05:03 EDT
Run vncpasswd.
Comment 11 Bob Gustafson 2004-06-01 14:39:54 EDT
OK, cool - vncpasswd was the key to encourage vncserver to create a
new bunch of files in /home/user1/.vnc and come up at boot time.

The default window manager for vncserver is quite primitive. However,
when it is up and running, my regular console desktop (startx after
login as user1) has the correct fonts.

When I go into /home/user1/.vnc/xstartup and uncomment the two lines:

  [user1@hoho2 user1]$ more .vnc/xstartup
  #!/bin/sh
 
  # Uncomment the following two lines for normal desktop:
  unset SESSION_MANAGER
  exec /etc/X11/xinit/xinitrc
 
Now, on boot, the vncserver comes up - the vnc desktop has nice big
fat fonts on the Gnome menu, but the console desktop now has the thin
default fonts.

This is back to where I started this bug report.

Comment 12 Bob Gustafson 2004-06-01 21:10:38 EDT
-- I will be 'unplugged' till next Monday (family vacation) --
Comment 13 Bob Gustafson 2004-07-03 14:14:03 EDT
I could not boot into the smp kernel for a few days, so finally I
tried to boot into the single processor kernel

[root@hoho2 user1]# cat /proc/version
Linux version 2.6.7-1.469 (bhcompile@daffy.perf.redhat.com) (gcc
version 3.4.0 20040621 (Red Hat Linux 3.4.0-7)) #1 Sat Jul 3 03:33:19
EDT 2004

Using the SP version, it does come up.

And, this font problem I was having for the last couple of months
seems to have gone away.

I don't know why the smp version of the kernel would cause font
problems, but the single processor version works for me.

Note You need to log in before you can comment on or make changes to this bug.