Bug 122213 - rpm has "segmentation faults"
rpm has "segmentation faults"
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 19:21 EDT by renee
Modified: 2007-04-18 13:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 09:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpm -ivv output (2.53 KB, text/plain)
2004-05-04 21:33 EDT, renee
no flags Details

  None (edit)
Description renee 2004-05-01 19:21:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.9)
Gecko/20020604

Description of problem:
I am using yellowdog linux 2.3, and after upgrading from glibc 2.2.5
to glibc 2.3.1, rpm no longer works.  Everything else works fine, but
rpm has "segmentation faults"

I have tried rebuilding the rpm database numerous times, however that
does not seem to do anything.

Version-Release number of selected component (if applicable):
rpm-4.0.3-1.03b

How reproducible:
Always

Steps to Reproduce:
To reproduce this, the only thing needed to do is to type rpm -ivh
whatever-1.2.ppc.rpm.

It happens as well for rpm -e whatever, and rpm -Uvh
whatever-1.2.3.ppc.rpm.

Actual Results:  after I type this and hit enter, it begins the
install process.  it prepares to 100%, but then as soon as it starts
to actually install, it stops and says "segmentation fault".

that's it.

Additional info:
Comment 1 Jeff Johnson 2004-05-04 09:34:41 EDT
Can you attach the output of rpm -ivv?
Comment 2 renee 2004-05-04 21:33:04 EDT
Created attachment 99972 [details]
rpm -ivv output

here is the output from rpm -ivv ffcall...
Comment 3 renee 2004-05-04 21:43:33 EDT
I uploaded the output from rpm -ivv as an attachment, but I am not
sure if it sent, so I will send it again, but not as an attachment.

Here it is:


[root@localhost renee]# rpm -ivv ffcall-1.9-1.ppc.rpm 
D: ============== ffcall-1.9-1.ppc.rpm
D: Expected size:       118789 =
lead(96)+sigs(180)+pad(4)+data(118509)
D:   Actual size:       118789
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: locked   db index       /var/lib/rpm/Packages
D:      added binary package [0]
D: found 0 source and 1 binary packages
D: ========== +++ ffcall-1.9-1
D: opening  db index       /var/lib/rpm/Depends create mode=0x42
D: opening  db environment /var/lib/rpm/Basenames joinenv
D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
D:  Requires: /sbin/ldconfig                                YES (db
files)
D:  Requires: R /sbin/ldconfig                              YES
(cached)
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(VersionedDependencies) = 3.0.3-1
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(CompressedFileNames) = 3.0.4-1
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(PayloadIsBzip2) = 3.0.5-1
D:   YES    A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(PayloadFilesHavePrefix) = 4.0-1
D:  Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1       YES (rpmlib
provides)
D:   NO     A rpmlib(CompressedFileNames) <= 3.0.4-1    B
rpmlib(VersionedDependencies) = 3.0.3-1
D:   YES    A rpmlib(CompressedFileNames) <= 3.0.4-1    B
rpmlib(CompressedFileNames) = 3.0.4-1
D:  Requires: rpmlib(CompressedFileNames) <= 3.0.4-1        YES (rpmlib
provides)
D: opening  db environment /var/lib/rpm/Providename joinenv
D: opening  db index       /var/lib/rpm/Providename create mode=0x42
D:  Requires: libc.so.6                                     YES (db
provides)
D:  Requires: libc.so.6(GLIBC_2.0)                          YES (db
provides)
D:  Requires: libc.so.6(GLIBC_2.1.3)                        YES (db
provides)
D: opening  db environment /var/lib/rpm/Conflictname joinenv
D: opening  db index       /var/lib/rpm/Conflictname create mode=0x42
D: ========== recording tsort relations
D: ========== tsorting packages (order, #predecessors, #succesors,
depth)
D:     0    0    1  0  ffcall-1.9-1
D: installing binary packages
D: getting list of mounted filesystems
D: opening  db environment /var/lib/rpm/Name joinenv
D: opening  db index       /var/lib/rpm/Name create mode=0x42
Preparing packages for installation...
D: Expected size:       118789 = lead(96)+sigs(180)+pad(4)+data(118509)
D:   Actual size:       118789
D:   install: ffcall-1.9-1 has 35 files, test = 0
Segmentation fault
Comment 4 Vladimir Guzmán 2004-05-05 20:30:25 EDT
I've got the same problem.
For example:
rpm -evv esound:
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Pubkeys rdonly mode=0x0
D:  read h#     135 Header V3 DSA signature: NOKEY, key ID db42a60e
D: ========== --- esound-0.2.28-1
D: opening  db index       /var/lib/rpm/Requirename rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Pubkeys
D: closed   db index       /var/lib/rpm/Requirename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: getting list of mounted filesystems
D: sanity checking 1 elments
D: computing 69 file fingerprints
D: computing file dispositions
D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
D: ========== --- esound-0.2.28-1
D:     erase: esound-0.2.28-1 has 69 files, test = 0
D: opening  db index       /var/lib/rpm/Name create mode=0x42
D: opening  db index       /var/lib/rpm/Pubkeys create mode=0x42
D:  read h#     135 Header V3 DSA signature: NOKEY, key ID db42a60e
Segmentation fault



Thanks a lot
Comment 5 renee 2004-05-14 15:39:29 EDT
Hello?

Is anyone going to get back to me?

(I don't mean to sound rude or impatient, but it's been over a week
since I posted that requested information, and I would like my rpm to
work again.)

:)

Thanks

Renee
Comment 6 Vladimir Guzmán 2004-05-14 17:39:22 EDT
Hello, Renee.

I have a work-around, maybe you could try.
I can't use:
rpm -i
rpm -U
rpm -e
But I do can use:
/usr/lib/rpm/rpmi
/usr/lib/rpm/rpmu
/usr/lib/rpm/rpme

with the same options rpm use

Vladimir Ilich Guzmán R.
------------------------
http://maintask.com 
Comment 7 renee 2004-05-14 21:13:36 EDT
Thank you very much

that's works perfectly!

Renee
Comment 8 Jeff Johnson 2004-06-16 09:04:51 EDT
Problem appears resolved.

Note You need to log in before you can comment on or make changes to this bug.