Bug 122215 - (SATA SI3114) Silicon Image SATA Driver Not Included in fedora installer
(SATA SI3114) Silicon Image SATA Driver Not Included in fedora installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 121844 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 20:16 EDT by Corey T
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey T 2004-05-01 20:16:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
On boot when choosing a extra driver for SCSI and other devices not
detected on boot it does not have Silicon Image drivers listed at all.
 They're in the vanilla kernel off kernel.org.

Silicon Image is the broadcom of SATA and SATA Raid chipsets on
consumer motherboards and are one of the cheaper addon cards out
there.  As more users wish to adopt SATA hard drives and other
components this will cause problems.

These need to be included at release.

Version-Release number of selected component (if applicable):
2.6.5 Stock with Test 3

How reproducible:
Always

Steps to Reproduce:
1. Boot check in installer.

Actual Results:  You cannot continue with installation.  Only work
around would be to compile  driver disk and this is unacceptable to
any standard user.

Expected Results:  User would have been able to continue with
installation.

Additional info:
Comment 1 Alan Cox 2004-05-02 18:53:30 EDT
*** Bug 121844 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2004-05-03 14:07:23 EDT
Added to module-info.
Comment 3 Dag Wieers 2004-05-22 19:32:38 EDT
Is the SiL 3114 supposed to work with FC2 ? My disks are detected,
still I get a lot of lost interrupts on my SATA disks and the
installation doesn't really proceed properly because of that.
Comment 4 Dag Wieers 2004-05-22 20:23:01 EDT
Ok, forget that last remark. The Abit KV8-MAX3 has 6 SATA connections,
of which the first 2 are VIA RAID and the next 4 are the SiL 3114.
Both BIOSes aren't very clear about this, nor is the documentation.

FC2 works with the SiL 3114, but not with the VIA RAID Chipset.

What puzzles me, though, is that although I have both disks configured
as RAID1 and the BIOS clearly has it configured as 1 logical disk,
Linux still sees both disks as sda/sdb.
Comment 5 Chris Whitehorn 2004-05-31 22:20:36 EDT
well The driver actually works in Core 2 but I still want the raid
version to be in here. In other words, it sees my SATA single drives
but it doesnt see my RAID'ed drives.
Comment 6 Matt D 2004-07-10 04:49:07 EDT
Has there been any progress getting FC2 to recognize the single RAID
drive instead of each individual drive?
Comment 7 Rahul Sundaram 2005-08-15 12:12:46 EDT
Any progress on this one?

Note You need to log in before you can comment on or make changes to this bug.