Bug 122219 - Unusable configuration of Gateway VX900 monitor after install
Unusable configuration of Gateway VX900 monitor after install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 21:37 EDT by Stan Wong
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stan Wong 2004-05-01 21:37:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
FC2T3 does not detect a Gateway VX900 monitor correctly during
installation leaving the system non-responsive after installation and
reboot.  A hard reboot with a rescue disk is required to edit the
xorg.conf file to a useful configuration.  The system has a
motherboard by an unknown manufacturer and has an AMD Athlon XP-M
1400+ processor and S3 SavagePro KM133 graphics core.

Results differ depending on if the installation process probes for the
monitor or if the actual monitor is selected, or a generic monitor is
selected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Let the installer probe for VX900 monitor
2. Or specify a generic 1024x768 monitor
3.
    

Actual Results:  If the monitor is probed, it is not detected. 
Selecting Gateway VX900 leads to a system lockup after installation
and reboot.  The problem can be fixed by booting another OS and
editting xorg.conf.  The lockups do not occur if a Generic monitor is
specified but the resolution is incorrectly set.

Expected Results:  1. Correct probing for Gateway VX900 monitor.

-or-

2. Correct configuration of resolution as specified during install.

Additional info:

During installation, the default DDC probe does not detect a monitor.
 I can select 'Gateway' then 'VX900'.  Note that there are two VX900
selections available and both give the same results.  The S3 graphics
is correctly detected.  Once the system is rebooted and hangs, the
only way to recover is to use a rescue disk (I used Knoppix) to edit
the /etc/X11/xorg.conf file.  If I uncomment the selections in the
monitor section:
----------------------------
Section "Monitor"
                                                                     
          
 ### Uncomment if you don't want to default to DDC:
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor 1024x768"
 ### Uncomment if you don't want to default to DDC:
        HorizSync    31.5 - 57.0
        VertRefresh  50.0 - 70.0
        Option      "dpms"
EndSection
----------------------------
then after a reboot things start to work properly.

Note that this problem exists in Fedora Core 1 with XFree86 as well.

Partial Workaround:

During installation, select the 'Generic Monitor' instead of 'DDC
Probe'.  Sub-select 1024x768 screen resolution.  When rebooting,
during firstboot, you get a selection of 640x480 resolution with the
option of selecting 800x600.  Selecting 800x600 lets you boot
succesfully.  The monitor section of xorg.conf looks like this:
----------------------
Section "Monitor"
                                                                     
          
 ### Uncomment if you don't want to default to DDC:
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor 1024x768"
 ### Uncomment if you don't want to default to DDC:
 #       HorizSync    31.5 - 57.0
 #       VertRefresh  50.0 - 70.0
 #      Option      "dpms"
EndSection
---------------------

You can then go to xorg.conf and uncomment the HorizSync and
VertRefresh lines and get back to 1024x768 resolution.

During firstboot, the 1024x768 resolution is not offered as an option
even though it was selected during installation and the following is
in the xorg.conf:
----------------------
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1024x768" "800x600" "640x480"
-----------------------

Operation is fine after that.

Note You need to log in before you can comment on or make changes to this bug.