Bug 122277 - Sound output to wrong soundcard
Sound output to wrong soundcard
Status: CLOSED DUPLICATE of bug 81843
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2004-05-02 12:42 EDT by Jean-Pascal Houde
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jean-Pascal Houde 2004-05-02 12:42:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
I tested Fedora Core on a system with two sound cards.
One is onboard (Realtek ALC200/200P according to Fedora)
The other is a Sound Blaster Audigy2 platinum.

In the first boot configuration, I select the Audigy 2 as the primary
The speakers where connected on the Audigy 2, and I didn't hear the
sound test.

Later, I realized that the sound was output in the onboard soundcard.

If I rerun system-config-sound-card, the onboard soundcard is still
selected as the primary device.

I have updated my system using yum after installing.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install FC2T3
2.Select Audigy 2 as primary sound card
3.Open an ogg file using Rythmbox.

Actual Results:  I hear sound only when I plug speakers in the onboard

Expected Results:  The Audigy 2 is selected as the default sound card.

Additional info:

Content of modprobe.conf : 
alias eth0 dmfe
alias snd-card-0 snd-via82xx
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-1 snd-emu10k1
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
Comment 1 Alan Cox 2004-05-02 17:31:56 EDT
The dump data matches that the onboard sound is primary.
Comment 2 Jean-Pascal Houde 2004-05-02 18:02:55 EDT
Yes, swapping snd-card-0 and snd-card-1 in modprobe.conf made the
Audigy 2 the primary sound card.
However, the "Primary audio device" select box in
system-config-soundcard doesn't seem to do anything.
Comment 3 Bastien Nocera 2004-07-22 05:06:10 EDT

*** This bug has been marked as a duplicate of 81843 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.