Bug 122292 - Nautilus cannot view SMB shares
Nautilus cannot view SMB shares
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 125336 129398 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 14:20 EDT by Scott Phipps
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 10:08:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Phipps 2004-05-02 14:20:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
When I go to the Network Servers entry under the main menue, it brings
up a window with a Windows Network icon.  If I click on that, I get
nothing.  Entering the location of the smb share directly does not
work either.

Version-Release number of selected component (if applicable):
2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1.Click on Network Servers to bring up Nautilus
2.
3.
    

Actual Results:  brings up a window with a Windows Network Icon that
brings up an empty window when clicked.

Expected Results:  Clicking on the Windows Network Icon would show me
the other computers on the network.

Additional info:

I cannot get it to view the smb shares, even if I give it the direct
address (such as smb://workgrop/computername/sharename). If I give it
smb://workgroup then it will show the other computers on the network,
but when I click on the icons, it complains about setting the correct
file type.
Comment 1 Alan Cox 2004-05-02 17:25:58 EDT
Do you have firewalling configured ? And if so does turning it off help ?
Comment 2 Scott Phipps 2004-05-02 18:30:43 EDT
No, I selected no firewallduring the install.  I went ahead and
stopped iptables anyway and tried to access the shares, but had the
same results.
Comment 3 Scott Phipps 2004-05-09 00:20:00 EDT
I discovered that if I use an ip address (ie smb://192.168.1.X), then
it works as expected when using the option open location.
Comment 4 Jean-Francois Saucier 2004-06-08 09:56:45 EDT
Don't work in Fedora Core 2 final also.

I have no firewall on my laptop.
Comment 5 Bryan Christ 2004-06-15 17:44:34 EDT
I also have the same problem.  However, using the IP address does not
work for me as it did for comment #3.  I am using Fedora Core 2 final
with Nautilus in "classic" mode.
Comment 6 Don Himelrick 2004-06-24 11:28:16 EDT
smb:/// worked for me in FC1, now it doesn't in FC2.  Any workarounds?
Comment 7 Don Himelrick 2004-06-24 11:40:44 EDT
smb://hostname    works though.  Shouldn't the FC version for this bug
 be changed from test3 to 2?
Comment 8 Don Himelrick 2004-06-24 12:52:31 EDT
I apologize for all the short posts on this, I'm not really up on the
"bugzetiquette" for tying together different bugs reports assigned to
different components/people.   But I believe the componoent for this
should be gnome-vfs2 and that it might be a duplicate of bug 123899,
but it is more likely a duplicate of bug 125336.

See my comment #5 on bug 123899.
Comment 9 Don Himelrick 2004-06-24 13:03:00 EDT
Wow, bugzilla tried to outsmart me and made a link to the comment I
mentioned above, only it made it to #5 of this bug.  Here is the
correct link.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123899#c5

Comment 10 Matthew Ross 2004-06-30 13:04:45 EDT
*** Bug 125336 has been marked as a duplicate of this bug. ***
Comment 11 Matthew Ross 2004-06-30 13:07:08 EDT
I took a minute to look at the Gnome Bugzilla, and found that it may
not be a Fedora Core 2 bug, but one for all of Gnome-Nautilus.

Check the follwing bug in Gnome's Bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=129890
Comment 12 Scott Hopkins 2004-09-15 22:48:44 EDT
Modify the following file as noted below and this will fix your problem.

/etc/gnome-vfs-2.0/modules/smb-module.conf
	#smb: [daemon] libsmb ----> commented out
	smb:    libsmb.so ----> added
Comment 13 Alan Cox 2004-09-16 10:45:28 EDT
Mine already has that but smb seems to be missing from the "default'
mapping thing. Dunno if that is relevant
Comment 14 Don Himelrick 2004-09-16 10:47:58 EDT
The above comment #12 fixed my smb:/// problem on FC2.
Comment 15 Alexander Larsson 2004-09-16 11:01:27 EDT
Thats strange. The daemon stuff shouldn't really affect that. The smb
code is designed to run in the daemon.
Comment 16 Alexander Larsson 2004-09-16 11:04:15 EDT
Maybe the daemon crashes, can you start it under gdb and see what
happens to it when you start using smb://
Comment 17 Don Himelrick 2004-09-16 11:21:50 EDT
Not sure what you want...  is this what your asking?

1. Change back to "smb: [daemon] libsmb" in smb-module.conf
2. Start gnome-vfs-daemon under gdb (not sure when or how to do that)
3. Use smb:/// in nautilus and see what happens

I you can elaborate on #2, I would be happy to do this.  Or, if I'm
completely wrong, tell me what you would like.
Comment 18 Alexander Larsson 2004-09-16 11:32:49 EDT
in a shell, type:

gdb /usr/libexec/gnome-vfs-daemon
run

and then use smb://. If it crashes or something you should get gdb
output. Then get a backtrace. See:
http://fedora.linux.duke.edu/wiki/StackTraces
Comment 19 Don Himelrick 2004-09-16 16:42:09 EDT
Hmmm...  Is it possible that this was fixed by the
samba-3.0.7-2.FC2.i386 packages on 9-14-04?  I know I've tried this
sometime in the past few weeks and it didn't work, but now it works
with either of the above smb: entries in
/etc/gnome-vfs-2.0/modules/smb-module.conf.   So maybe the conf file
is not responsible.  I booted up my laptop which is stock FC2 with
updates and no conf changes and it works there as well.  So, for me
anyway, this has started working sometime in the last few weeks and I
didn't notice until I made the (apparently irrelevant?) change in the
smb-module.conf file.
Comment 20 Alexander Larsson 2004-09-17 06:06:18 EDT
The change in smb-module.conf is quite wrong, but i'd like to know
where it came from, as it might point to some bug in the daemon handling.
Comment 21 Scott Hopkins 2004-09-17 13:35:01 EDT
All I can tell you is that I was having the same problem everyone else
does and I compared my gnome config files on my FC2 workstation with
those of my FC1 server.  

The FC1 server has - "smb:    libsmb.so"
The FC2 workstation had - "smb: [daemon] libsmb"

Once I changed the FC2 workstation to "smb:    libsmb.so", it worked.
Comment 22 Don Himelrick 2004-09-19 14:46:07 EDT
O.K., I just did a fresh install of FC2 (no updates yet) and smb:///
did not work.  After running up2date and updating alot of packages, it
now works.  So it looks like one of the updates since the final
release of FC2 has fixed this problem.
Comment 23 Alexander Larsson 2004-09-21 10:08:08 EDT
I'll close it then.
Comment 24 Alexander Larsson 2004-09-21 10:08:57 EDT
*** Bug 129398 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.