Bug 122314 - Hotplug does not notice Apple trackpad
Summary: Hotplug does not notice Apple trackpad
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-03 01:21 UTC by W. Michael Petullo
Modified: 2014-03-17 02:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 00:32:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2004-05-03 01:21:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040422 Epiphany/1.1.12

Description of problem:
The Linux kernel treats the trackpad on my iBook as an Apple Desktop
Bus device, supported by the mousedev driver.  Since it is not a USB
device, hotplug does not recognize it.  The result is that the
mousedev kernel module is not loaded when I boot my iBook without a
USB mouse attached and X does not start.

This may actually need to be fixed in /etc/rc.d/rc.sysinit.  For old
kernel versions, /etc/rc.d/sysinit inserts mousedev manually.  For
recent kernels, however, sysinit depends on hotplug to load mousedev.

Version-Release number of selected component (if applicable):
hotplug-2004_03_11-1

How reproducible:
Always

Steps to Reproduce:
1.  Boot with no USB mouse connected to my iBook.  The mousedev module
is not loaded and X fails to load.  If I insert the mousedev module by
hand X starts fine.

2.  Boot with a USB mouse plugged in.  In this case the mousedev
driver is inserted on booting and X starts fine.
    

Additional info:

Comment 1 Colin Charles 2004-08-30 00:11:41 UTC
What iBook is this? G3/G4 and if G3, which generation? /proc/cpuinfo
details would be good, if you're unsure

Also, is this still a bug with Rawhide latest?

(because I have tested on a iBook g3 2.2 and an iBook g4, and it seems
to all "just work")

Comment 2 W. Michael Petullo 2004-09-01 00:32:58 UTC
Yes, this is still the case.  However, I just learned (correct me if
I'm wrong) that the Red Hat kernel does not compile mousedev as a
module.  So, there is no need for hotplug to load mousedev in this case.

I use a custom kernel and my mousedev driver is compiled as a module.
 I suppose that this means that this is not a bug.

Comment 3 Colin Charles 2004-09-01 14:43:02 UTC
Well, I'd really like to know what kinda Apple you're using, because
its not a visible bug for me (WORKSFORME)


Note You need to log in before you can comment on or make changes to this bug.