This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 122316 - gdm suddenly crashing
gdm suddenly crashing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 01:38 EDT by Deji
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 08:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji 2004-05-03 01:38:04 EDT
Description of problem:
I've twice experienced gdm suddenly crashing while in a gnome-session.
When this happens, X get killed ( just as if i did ctr-alt-backspace),
dropping me back at login screen. Unfortunately, i've not noticed any
particular pattern that produced this crash, but the last time it
happened i checked the system-log on logging back in and found the fflg;
<<
May  2 21:44:31 rhema modprobe: FATAL: Error running install command
for sound_slot_1 
May  2 21:45:12 rhema gconfd (deji-2758): Received signal 15, shutting
down cleanly
May  2 21:45:12 rhema gdm[2402]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
May  2 21:45:12 rhema gdm(pam_unix)[2402]: session closed for user deji
May  2 21:45:12 rhema gconfd (deji-2758): Exiting
May  2 21:45:17 rhema kernel: agpgart: Found an AGP 2.0 compliant
device at 0000:00:00.0.
May  2 21:45:17 rhema kernel: agpgart: Putting AGP V2 device at
0000:00:00.0 into 4x mode
May  2 21:45:17 rhema kernel: agpgart: Putting AGP V2 device at
0000:01:05.0 into 4x mode
May  2 21:45:24 rhema gdm(pam_unix)[2901]: session opened for user
deji by (uid=0)
May  2 21:45:25 rhema gconfd (deji-2994): starting (version 2.6.0),
pid 2994 user 'deji'
May  2 21:45:25 rhema gconfd (deji-2994): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only config
source at position 0
May  2 21:45:25 rhema gconfd (deji-2994): Resolved address
"xml:readwrite:/home/deji/.gconf" to a writable config source at
position 1
May  2 21:45:25 rhema gconfd (deji-2994): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config
source at position 2
May  2 21:45:26 rhema modprobe: FATAL: Error running install command
for sound_slot_1 
>>  

Version-Release number of selected component (if applicable):


How reproducible:
Not easily reproducible

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The 2nd occurence happened about 2/3 days after the 1st.
Comment 1 Mark Rush 2004-05-03 12:21:39 EDT
I've seen this twice in the last six days: system logs me out sometime
overnight and is waiting at the gui login prompt when I come in in the
morning. So far it has happened overnight when system is in
screensaver, different times. System log:

fedoracore gconfd (mark-1660): Received signal 15, shutting down cleanly
fedoracore gdm[1597]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
fedoracore gdm(pam_unix)[1597]: session closed for user mark

System: P4 3.0 w/HT, Asus P4C800-E Dlx mbd, 2G PC3200 DDR, geForce FX
5900, onboard audio and nic, 40G ata hdd, 80G seagate SATA hdd.
Comment 2 Mark Rush 2004-05-04 12:09:47 EDT
Appears to be random when this occurs, has happened also while at
gnome desktop during active session.
Comment 3 Mark Rush 2004-05-08 12:33:08 EDT
Still seeing this; system up2date as of 4-8-04.  Seems random as to
time and activity level.  System logs show nothing that seems out of
the ordinary prior to gconfd getting signal 15.  This has happened
also without the gconfd error, starting instead with
gdm_slave_xioerror handler error.
Comment 4 Geert Theys 2004-05-18 07:19:20 EDT
May 18 13:10:06 monster gconfd (gt-5055): Received signal 15, shutting
down cleanly
May 18 13:10:06 monster gconfd (gt-5055): Exiting

Same here:
----------

System: dell latitude d800, wuxga screen and geforce go card. Looks
randome, but I get it 4 or 4 times a day. I'm completely updated to
tue may 18.
Comment 5 Geert Theys 2004-05-18 07:20:19 EDT
Can't reproduce, just happens like random.
Comment 6 Mark Rush 2004-05-20 12:15:22 EDT
Still seeing this with FC2 final, about twice a day.  All but once has
started with "gconfd (mark-2436): Received signal 15, shutting down
cleanly", followed by "gconfd (mark-2436): Exiting" and then
"gdm[2343]: gdm_slave_xioerror_handler: Fatal X error - Restarting
:0".  System does not reboot, just logs user out and returns to the
login prompt.
Comment 7 Mark Rush 2004-05-22 21:33:17 EDT
Sorry, turns out I'm having hardware problems.
Comment 8 Mark McLoughlin 2004-06-04 08:06:56 EDT
fedoracore gdm[1597]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0


This means the X server crashed - you'll need to log bugs against the
xorg-x11 package with detail description of your hardware, X error
logs etc. It would also be worth looking through existing xorg-x11
bugs to see if it has already been reported.

(Closing as NOTABUG - a new xorg-x11 bug would be more useful that
transferring this bug)

Note You need to log in before you can comment on or make changes to this bug.