Bug 122318 - cdrecord unable to burn BIN/CUE image files
Summary: cdrecord unable to burn BIN/CUE image files
Status: CLOSED DUPLICATE of bug 119906
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrtools   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-03 06:02 UTC by Alexei Dets
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexei Dets 2004-05-03 06:02:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
This version of cdrecord is unable to burn BIN/CUE image files, it just prints error messages and does _nothing_:

$ /usr/bin/cdrecord -v gracetime=2 dev=0,0,0 speed=24 -dao driveropts=burnfree cuefile=VIDEOCD.cue -overburn
/usr/bin/cdrecord: No tracks specified. Need at least one.
Usage: /usr/bin/cdrecord [options] track1...trackn

Use     /usr/bin/cdrecord -help
to get a list of valid options.

Use     /usr/bin/cdrecord blank=help
to get a list of valid blanking options.

Use     /usr/bin/cdrecord dev=b,t,l driveropts=help -checkdrive
to get a list of drive specific options.

Use     /usr/bin/cdrecord dev=help
to get a list of possible SCSI transport specifiers.

$ man cdrecord
-----
cuefile=filename
	Take all recording related information from a  CDRWIN compliant CUE sheet file. No track files are allowed when this option is present and the option -dao is currently needed in addition.
-----

So, as you can see, it seems to be related to incorrect command line parsing - it expects track file even with "cuefile" parameter.

If I recompile the source rpm package without cdrtools-2.01a27-dvd.patch than cdrecord works as expected - burns an image file (it is a _CD_ image, not DVD). My writer is capable of DVD writing also - it is an MSI DVD DUAL 4X drive, may be this causes bad interaction with dvd-patch...

Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a27.2

How reproducible:
Always

Steps to Reproduce:
1. Try to burn some BIN/CUE image with cdrecord using "cuefile" parameter.

Actual Results:  Will do nothing except error report: No tracks specified. Need at least one.

Expected Results:  Should burn the image.

Additional info:

Comment 1 Rex Dieter 2004-05-03 14:23:42 UTC
Appears to be a dup of bug #119906

Comment 2 Harald Hoyer 2004-05-06 10:13:42 UTC

*** This bug has been marked as a duplicate of 119906 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:02:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.