Bug 122323 - SWIG Perl bindings don't compile under Fedora Core
SWIG Perl bindings don't compile under Fedora Core
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: swig (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
http://www.swig.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 02:56 EDT by Scott Finneran
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 10:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Finneran 2004-05-03 02:56:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
The version of SWIG supplied with Fedora Core is incompatible with
either the compiler or libraries included with the distro. I supplied
a patch to fix this to the SWIG people which was included in
swig-1.3.20 (and above). This new release needs to be included with
Fedora Core so that the patch is included and perl bindings will compile. 

I have tested 1.3.21 (compiled from tarball) and it works fine (while
1.3.19 from the RPM does not).

I am not aware of RPMs existing for this version of the swig package.

Version-Release number of selected component (if applicable):
1.3.19

How reproducible:
Always

Steps to Reproduce:
1. Attempt to compile examples from swig website for perl bindings
under gcc (version included with Fedora Core). That's it.
    

Actual Results:  The compile fails due to the new version of GCC being
much more picky about types in function calls.

Expected Results:  It should have failed because this old version of
swig was pretty relaxed about types. The new version fixes this.

Additional info:
Comment 1 Phil Knirsch 2004-05-04 10:04:19 EDT
OK, updated swig to 1.3.21. Needed to tweak some minor things but
compiles just fine on current tree.

Not sure if it will make it into FC2, but it will certainly be in the
following release.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.