Bug 122325 - mkinitrd default initrd size too small for 2.6.5 kernel
mkinitrd default initrd size too small for 2.6.5 kernel
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-05-03 04:06 EDT by Howard Wilkinson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.5.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-02 17:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to imagesize for mkinitrd and new-kernel-pkg (1.15 KB, patch)
2004-05-03 04:09 EDT, Howard Wilkinson
no flags Details | Diff

  None (edit)
Description Howard Wilkinson 2004-05-03 04:06:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
Mkinitrd runs out of space when creating a 2.6.5 initrd for i686
platform. The size in the code is 4000 for an i386 box and 8000 for an
i686 box. The machines being used require aic7xxx, dm-mod, raid0,
scsi_mod, sd_mod, jbd and ext3 to be preloaded to operate.

I have a patch that allows the size to be specified to mkinitrd on the
command line and a patch to new-kernel-pkg to increase the size to
12000 by default.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Try to install a kernel on a machine with modules requirements as above

Actual Results:  Kernel would not boot properly as the modules did not

Expected Results:  Kernel boots when fixed.

Additional info:
Comment 1 Howard Wilkinson 2004-05-03 04:09:12 EDT
Created attachment 99898 [details]
Patch to imagesize for mkinitrd and new-kernel-pkg

Add a option to mkinitrd for the imagesize and use this from new-kernel-pkg to
set the size to 12000
Comment 2 Jeremy Katz 2004-05-06 21:42:56 EDT
This route isn't as good as the ramdisk size in the kernel is only set
ot 8 megs.  So I bumped to 8 megs across the board in mkinitrd.
Comment 3 Jeremy Katz 2004-05-06 21:43:02 EDT
This route isn't as good as the ramdisk size in the kernel is only set
ot 8 megs.  So I bumped to 8 megs across the board in mkinitrd.
Comment 4 Howard Wilkinson 2004-05-07 04:20:39 EDT
Increasing the kerneal RAM disk is not going to fix this problem. The
images run out of space at 8 megs when being built. I am having to run
the kernel we boot with 32 Meg RAMDISKS. (16 Meg was failing and I
only tried a power of 2). You need this fix to build the anaconda
images for the pxeboot with aic7xxx, LVM and RAID drivers plus e100 or
e1000 drivers in my case (which also needs mii).

Another fix is needed if you embed these drivers in the kernel as
new-kernel-img fails to account for mkinitrd reporting it cannot find
a module (already built in) and of course does not provide any
interface to tell mkinitrd that this is so.
Comment 5 Ben Hsu 2004-05-26 01:14:23 EDT
I believe I am hitting this bug. The initrd generated is only ~100K
compared to ~200K for the initrd shipped. This happens even when I
compile the kernel shipped with FC2. Does this sound like this bug or
should I open a new bug?
Comment 6 Ted Kaczmarek 2004-05-27 15:54:52 EDT

I appear to ge hitting this as well, was wondering why the files were
so much smaller. I also noticed that I would get random sizes for my
initrd when trying to create one manually.

276009 initrd-2.4.20-20.9.img
191404 initrd-2.6.5-1.358smp.img

Tried mkinitrd-3.5.23-1 as well, no joy.

Comment 7 Jeremy Katz 2004-08-02 17:58:33 EDT
With mkinitrd-4.x, we're moving to the creation of an initramfs
instead of an initrd and thus shouldn't hit this anymore

Note You need to log in before you can comment on or make changes to this bug.