Bug 122342 - After install, no services start, no firstboot, dumped to console login where everything segfaults
Summary: After install, no services start, no firstboot, dumped to console login where...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-03 15:09 UTC by Dan Mastrian
Modified: 2014-03-17 02:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 18:56:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Mastrian 2004-05-03 15:09:52 UTC
Description of problem:
After successfully installing FC2 test3 on Virtual PC 2004, I 
rebooted.  Immediately after init started, I was dumped to the text-
mode login (though the system should be trying to reach runlevel 5).  
Console output is included below.

Changing inittab to boot to runlevel 3 gets rid of the X error 
messages, but still nothing from rc.sysinit seems to run.

I've installed twice, with the exact same results both times.

The only processes running are:

[root@(none) root]# ps -A          
  PID TTY          TIME CMD        
    1 ?        00:00:08 init       
    2 ?        00:00:00 ksoftirqd/0
    3 ?        00:00:00 events/0   
    4 ?        00:00:00 kblockd/0  
    6 ?        00:00:00 pdflush    
    5 ?        00:00:00 khubd      
    7 ?        00:00:00 pdflush    
    9 ?        00:00:00 aio/0      
    8 ?        00:00:00 kswapd0    
   10 ?        00:00:00 kseriod    
   14 ?        00:00:00 kjournald  
   21 tty3     00:00:00 mingetty   
   24 tty6     00:00:00 mingetty   
   26 ?        00:00:01 login      
   27 tty2     00:00:00 mingetty   
   31 tty4     00:00:00 mingetty   
   32 tty5     00:00:00 mingetty   
  104 tty1     00:00:00 bash       
  134 tty1     00:00:00 ps    

Version-Release number of selected component (if applicable):


How reproducible:
2 of 2 times

Steps to Reproduce:
1. Install FC2 test3 on Virtual PC 2004
2. Reboot machine
3. Notice init begin to start, then dump you to text-mode login
  
Actual results:
1. init doesn't appear to run anything in rc.sysinit
2. Dumped to text-mode login prompt
3. Most commands segfault intermittently

Expected results:
1. init should start something :)
2. firstboot should run
3. Graphical startup

Additional info:

Comment 1 Dan Mastrian 2004-05-03 15:41:29 UTC
(forgot console output...)

Fedora Core release 1.92 (FC2 Test 3)
Kernel 2.6.5-1.327 on an i686
       
(none) login: /etc/X11/prefdm: line 35:    36 Segmentation fault      
which gdm
>/dev/null 2>&1
/etc/X11/prefdm: line 80:    46 Segmentation fault      unicode_start 
$SYSFONT 
SYSFONTACM         
/etc/X11/prefdm: line 39:    48 Segmentation fault      which 
$preferred >/dev/
ull 2>&1     
/etc/X11/prefdm: line 80:    56 Segmentation fault      unicode_start 
$SYSFONT 
SYSFONTACM         
/etc/X11/prefdm: line 80:    65 Segmentation fault      unicode_start 
$SYSFONT 
SYSFONTACM         
/etc/X11/prefdm: line 80:    81 Segmentation fault      unicode_start 
$SYSFONT 
SYSFONTACM         
/etc/X11/prefdm: line 80:    90 Segmentation fault      unicode_start 
$SYSFONT 
SYSFONTACM         
/etc/X11/prefdm: line 80:    99 Segmentation fault      unicode_start 
$SYSFONT 
SYSFONTACM         
INIT: Id "x" respawning too fast: disabled for 5 minutes

Comment 2 Bill Nottingham 2004-05-03 18:56:29 UTC
This looks like a virtual pc bug in how it emulates the CPU.


Note You need to log in before you can comment on or make changes to this bug.