Bug 122343 - xfs kernelspace bugs in test3
Summary: xfs kernelspace bugs in test3
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-03 15:11 UTC by Eric Sandeen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 01:14:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix direct userspace memory derefence in XFS bulkstat ioctl (6.44 KB, patch)
2004-05-04 17:42 UTC, Christoph Hellwig
no flags Details | Diff
Fix /proc entry removal order in XFS (849 bytes, patch)
2004-05-04 17:44 UTC, Christoph Hellwig
no flags Details | Diff

Description Eric Sandeen 2004-05-03 15:11:37 UTC
Description of problem:
xfs kernel code in test3 contains some critical bugs:

1) module does not unload properly, due to incorrect removal of
   /proc entries

2) xfs_bulkstat interface directly accesses userspace memory, which
   will oops.  this interface is mainly used for xfsdump.

we (well, christoph) has patches for both of these, once they're
finalized (probably today) I'll attach them.

3) a couple large stack users still exist in xfs, I may attach
   some patches to reduce this, although for simple io stacks
   xfs seems fine in this respect.

Thanks,

-Eric

Comment 1 Christoph Hellwig 2004-05-04 17:42:30 UTC
Created attachment 99962 [details]
Fix direct userspace memory derefence in XFS bulkstat ioctl

Comment 2 Christoph Hellwig 2004-05-04 17:44:36 UTC
Created attachment 99963 [details]
Fix /proc entry removal order in XFS


Note You need to log in before you can comment on or make changes to this bug.