Bug 122348 - card reader kills mouse
card reader kills mouse
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: basesystem (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 11:47 EDT by e.mergl
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:53:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description e.mergl 2004-05-03 11:47:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When I tried to install FC2-test3 the installation immediately
stopped. The last message was 'loading usb_storage'.
Because of bad eperiences during installation of Windows XP
I removed my usb card reader (Apacer 7 to 1). After this the 
installation was successfull.

After re-installing the card-reader the mouse is not working
anymore. It's a Logitech optical wheel mouse which is connected
to the PS2 port.
The same setup worked fine with RH9.


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. boot
2.
3.
    

Actual Results:  mouse is vivible but can not be moved

Expected Results:  mouse should be movable

Additional info:

xorg.conf:
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
EndSection
 

grep -i mouse Xorg.0.log
(**) |-->Input Device "Mouse0"
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
(==) RADEON(0): Silken mouse enabled
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "IMPS/2"
(**) Mouse0: Core Pointer
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded


grep -i mouse messages
May  3 17:30:17 edmund kernel: mice: PS/2 mouse device common for all mice
May  3 17:30:17 edmund kernel: input: ImExPS/2 Generic Explorer Mouse
on isa0060 /
Comment 1 e.mergl 2004-06-22 07:11:19 EDT
Retry with a new card-reader:
the new card reader is connected to an external USB port.
Booting without card reader and connecting the card reader
later on, fixes the problem.
Comment 2 Dave Jones 2004-11-29 05:01:18 EST
fixed in latest kernel update?
Comment 3 e.mergl 2004-12-23 01:55:59 EST
seems to be fixed with FC3  2.6.9-1.681_FC3.

Edmund

Note You need to log in before you can comment on or make changes to this bug.