Bug 122363 - cyrus-imap runs but does not allow cyradm command to be run
cyrus-imap runs but does not allow cyradm command to be run
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Depends On:
  Show dependency treegraph
Reported: 2004-05-03 14:31 EDT by Seth Doty
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-30 12:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Seth Doty 2004-05-03 14:31:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
After the update from FC1 cyrus-imapd runs but does not allow the
cyradm command to be run to add users and mailboxes or read allow the
switch to PAM authentication

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.upgrade from FC1
2.attempt to login (FAILED)
3.switch to cyrus user and attempt to run cyradm(FAILED)

Actual Results:  command not found error

Expected Results:  should run

Additional info:

it would make it easier to upgrade if this used PAM by default and
worked.  my IMAP access is down after the upgrade.  The service is
running correctly though.
Comment 1 Michael Ballard 2004-07-28 21:52:19 EDT
I had the same problem with cyradm. I went to cyrus-imapd's bugzilla,
and here's what came of that:

Comment 2 John Dennis 2004-07-29 13:02:06 EDT
cyradm is in the cyrus-imapd-utils rpm not the cyrus-imapd package, do
you have the cyrus-imapd-utils package installed? What does

% rpm -q cyrus-imapd-utils

Comment 3 John Dennis 2004-07-29 13:03:38 EDT
Adding Michael to the cc list
Comment 4 Michael Ballard 2004-07-29 20:37:59 EDT
I didn't have cyrus-imapd-utils installed, so I 

% yum install cyrus-imapd-utils

Now, when I execute

% cyradm

I get


but can't authenticate, so when I run

% cyradm localhost

I get no output, like it locks up or something...
Comment 5 John Dennis 2004-07-30 12:28:10 EDT
Did you su to the cyrus user, or login as the cyrus user before trying
to run cyradm? You have to have the cyrus identity to connect as an
admin to the server.

Did you set the cyrus user password?

Is the cyrus-imapd service running?
As root what output do you get when you say:

% service cyrus-imapd status

Comment 6 Michael Ballard 2004-07-30 18:43:26 EDT
I didn't change to the cyrus user...here's what I did:

[root@thesewer root]# service cyrus-imapd status
cyrus-master dead but pid file exists
[root@thesewer root]# service cyrus-imapd start
Starting cyrus-imapd: preparing databases... done.
[root@thesewer root]# service cyrus-imapd status
cyrus-master dead but pid file exists
[root@thesewer root]# su cyrus
bash-2.05b$ cyradm localhost

Extra line after bash-2.05b$ is all the output I get...so, I logged in
as the cyrus user:

-bash-2.05b$ cyradm
cyradm> authenticate
authenticate: no connection to server

Control-C'd that, tried cyradm localhost....

-bash-2.05b$ cyradm localhost
-bash-2.05b$ cyradm thesewer.net

Same things. Then the master thing clicked, and I tried 

% /usr/cyrus/bin/master &

as it says to do here:
http://thesewer.net/cyrusimapd/install-configure.html after it's all
installed, and I get:

[root@thesewer root]# /usr/cyrus/bin/master &
[1] 12935
[root@thesewer root]# service cyrus-imapd status
cyrus-master dead but pid file exists
[1]+  Exit 71                 /usr/cyrus/bin/master
[root@thesewer root]# /usr/cyrus/bin/master
[root@thesewer root]# service cyrus-imapd status
cyrus-master dead but pid file exists
[root@thesewer root]# tail /var/log/imapd.log
[root@thesewer root]#

I think I'm either missing something very simple, or my machine has
something very screwed up with it...
Comment 7 John Dennis 2004-08-02 11:50:34 EDT
Are you running a Red Hat rpm? We don't install /usr/cyrus/bin/master,
at least not in any current rpm's. You shouldn't have to start the
master process by hand, thats what init.d script does when you say
"service cyrus-imapd start". Also I can't find the error message
"cyrus-master dead but pid file exists" in our sources. 

You can set CYRUS_VERBOSE to get more debug information.

I assume you're root when you do "service cyrus-imapd start", it looks
like you are and you must be.

Are you sure /var/log/maillog is empty? That where messages are going
to go.

It sounds like the master pid file exists with the master stopped, it
shouldn't, after doing a service stop does /var/run/cyrus-master.pid
exist, if so remove the file.

Try adding -x to the top of the init.d script
(/etc/init.d/cyrus-imapd) to show you what it's doing when you do a
service request, that might provide a clue.

But you're right, something seems amiss on your system. What does rpm
-q cyrus-imapd report your rpm version as?

Comment 8 Michael Ballard 2004-08-02 18:50:11 EDT
OK, I feel really stupid. I didn't have a .pid file, so I completely
stopped cyrus-imapd:

% service cyrus-imapd stop


% service cyrus-imapd start

And now it seems to be working fine. I was able to set up the user
mailboxes and can connect to the server. So now my only problem is
setting up sendmail to deliver to the Cyrus system....?
Comment 9 John Dennis 2004-08-02 19:02:30 EDT
Look in /usr/share/doc/cyrus-imapd*/ you find lots of documentation,
including how to configure sendmail.

Time to really close this bug out, bugzilla != helpdesk
Comment 10 Michael Ballard 2004-08-02 19:08:05 EDT
Yup. Sorry, thanks for the help though.

Note You need to log in before you can comment on or make changes to this bug.