Bug 122371 - Not able to use "ar.csd" register in a program
Not able to use "ar.csd" register in a program
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
ia64 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 15:51 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 10:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-03 15:51:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
T312461; GIS IE6.0 Build 20031007)

Description of problem:
Not able to use "ar.csd" register in a program.
The compiler is giving the following error:
  unknown register name `ar.csd' in `asm'.

The program test program:

main()
{
   unsigned long val;
   
   __asm__ __volatile__ ("mov ar.csd=%0;;"::"r"(val): \
                         "ar.csd", "memory");
}

cc -c chk.c # (chk.c contains the above program)
chk.c: In function `main':
      11: unknown register name `ar.csd' in `asm'

I am trying to use "cmp8xchg16" instruction where I need
to use ar.csd. I don't get any errors for ar.ccv register usage.

The gcc version is 3.2.3 20030502 (Red Hat Linux 3.2.3-20)
The vanilla installation kernel (2.4.21-4.EL) is running.
It is a "Itanium 2" box.



                    

Version-Release number of selected component (if applicable):
gcc-3.2.3.20 

How reproducible:
Always

Steps to Reproduce:
1.See the description above for the sample test ...
2.
3.
    

Additional info:
Comment 1 Need Real Name 2004-05-05 10:49:34 EDT
The corresponding assembly code does recognize the ar.csd
register. So, the problem is not really are serious problem.
(Still, not sure why __asm__ with ar.csd complains)

Also, cmp8xchg16 is not implemented in itanium 2 anyway.
So, there is no need to use ar.csd......

Note You need to log in before you can comment on or make changes to this bug.