Bug 122390 - bad interpretation of locale
bad interpretation of locale
Status: CLOSED DUPLICATE of bug 121338
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 18:40 EDT by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 03:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2004-05-03 18:40:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040430

Description of problem:
I'm not a frequent user of Openoffice (I'm a LaTeX guy) but I noticed
a problem which annoys me as I like a uniform language-wise desktop
and which I think wasn't present in the openoffice.org package
originally released with Fedora Core 1:

Openoffice interprets the LC_CTYPE environment variable as a tip to
change the UI language. This is bad behavior as the variables that
could have that effect would be LC_ALL, LANG and LC_MESSAGES only.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-16

How reproducible:
Always

Steps to Reproduce:
1. set LC_CTYPE to fr_FR.UTF-8 (for instance)
2. oowriter
    

Actual Results:  Writer is in French.

Expected Results:  Writer should be in the language defined in LC_ALL,
LC_MESSAGES or LANG variables. As read in the manpage LC_CTYPE is for
"Character classification and case conversion" only.

Additional info:

I'm using the latest errata openoffice.org package for FC1.

My current locale is this:

LANG=en_US.UTF-8
LC_CTYPE=pt_PT.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME=C
LC_COLLATE=pt_PT.UTF-8
LC_MONETARY=pt_PT.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=pt_PT.UTF-8
LC_NAME=pt_PT.UTF-8
LC_ADDRESS=pt_PT.UTF-8
LC_TELEPHONE=pt_PT.UTF-8
LC_MEASUREMENT=pt_PT.UTF-8
LC_IDENTIFICATION=pt_PT.UTF-8
LC_ALL=

Note that I used fr_FR.UTF-8 as an example above to show that whatever
is in the rest of the variables is irrelevant, openoffice uses the
value in LC_CTYPE.
Comment 1 Dan Williams 2004-05-04 09:47:00 EDT

*** This bug has been marked as a duplicate of 121338 ***
Comment 2 Caolan McNamara 2004-10-28 03:28:41 EDT
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.