Bug 122404 - rpm -q segfault
Summary: rpm -q segfault
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 01:23 UTC by Nigel Horne
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 13:10:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm -qa -vv as requested (58.57 KB, text/plain)
2004-05-04 13:39 UTC, Nigel Horne
no flags Details

Description Nigel Horne 2004-05-04 01:23:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4.1)
Gecko/20031114

Description of problem:
rpm -q seg faults on my system. Something must have corrupted
the database, but that is not the issue here, the program should
be robust enough to cope with database corruptions without crashing.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 9
2. Upgrade to FC1
3. Run 'rpm -q'
    

Actual Results:  [njh@sian src]$ rpm -qa
gpg-pubkey-11f63c51-3c7dc11d
basesystem-8.0-2
perl-DateManip-5.40-30
perl-XML-Dumper-0.4-25
Glide3-20010520-25
bonobo-conf-0.16-5
autoconf-2.57-3
postgresql-7.3.4-3.rhl9
slocate-2.7-2
mozilla-nss-1.4.2-0.9.0
ethereal-0.10.3-0.90.1
Segmentation fault
[njh@sian src]$

Additional info:

Comment 1 Nigel Horne 2004-05-04 01:26:06 UTC
I have since found that the seg fault does not occur when I run 'rpm
-qa' as root. Maybe rpm segfaults when it can't open a file/resource?

Comment 2 Jeff Johnson 2004-05-04 13:33:05 UTC
Can you attach the output of rpm -qa -vv that segfaults?

Comment 3 Nigel Horne 2004-05-04 13:39:58 UTC
Created attachment 99953 [details]
Output of rpm -qa -vv as requested

Comment 4 Nigel Horne 2004-05-24 11:07:11 UTC
Any update on this? 

Comment 5 Jeff Johnson 2004-06-16 13:10:59 UTC
YOu have rpm-4.2.1 installed.

The likeliest explanation is a dangling ptr fixed in rpm-4.2.2-0.6 and
later.

Doing "rm -f /var/lib/rpm/Pubkeys" should make the segfault go away;
then doing --rebuilddb will recreate the Pubkeys index.

If that procedure "fixes", then you should upgrade to rpm-4.2.2-0.6 or
later.


Note You need to log in before you can comment on or make changes to this bug.