Bug 122407 - Patch to enable glib to compile with gcc 3.4
Patch to enable glib to compile with gcc 3.4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glib (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 22:26 EDT by Joseph Tate
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 22:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix build under gcc 3.4.0 (2.18 KB, patch)
2004-05-03 22:27 EDT, Joseph Tate
no flags Details | Diff

  None (edit)
Description Joseph Tate 2004-05-03 22:26:01 EDT
Description of problem:
With gcc 3.4.0, __PRETTY_FUNCTION__ and __FUNCTION__ became variables
likeunto __func__ instead of string literals which they were in
versions prior to 3.4.0.  This prevented glib from compiling while
using glib.  The patch I will very soon attach fixes this problem.


Version-Release number of selected component (if applicable):
All

Additional Information:

Please upstream if possible.
Comment 1 Joseph Tate 2004-05-03 22:27:09 EDT
Created attachment 99938 [details]
Patch to fix build under gcc 3.4.0

As promised, a patch to enable glib to build using gcc 3.4.
Comment 2 Matthias Clasen 2004-06-24 22:35:50 EDT
This has been fixed in Rawhide now.

Note You need to log in before you can comment on or make changes to this bug.