Bug 122409 - umb-scheme segfaults when loading prelude
umb-scheme segfaults when loading prelude
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: umb-scheme (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
:
: 145693 146109 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 22:33 EDT by Thomas Covello
Modified: 2013-07-02 19:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 08:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Covello 2004-05-03 22:33:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
% umb-scheme
Welcome to UMB Scheme, version 3.2  Copyright (c) 1988,1996 William R
Campbell.
UMB Scheme comes with ABSOLUTELY NO WARRANTY. This is free software and
you are free to redistribute it under certain conditions.
See the UMB Scheme Release Notes for details. Type Control-d to exit.
 
Loading /usr/share/umb-scheme/prelude.scheme...
 
Fatal Error: Segmentation Violation.
 
Reset (Use Control-d to quit UMB Scheme)
==>

Version-Release number of selected component (if applicable):
umb-scheme-3.2-32

How reproducible:
Always

Steps to Reproduce:
Run umb-scheme.

Actual Results:  Segfaults.

Expected Results:  Should run properly.
Comment 1 George Karabin 2004-05-26 22:16:54 EDT
The same behavior exists in the version shipped in the release
versions of FC1 and FC2 as well. The interpreter is pretty much
useless like this - the prelude defines any number of useful language
features, like "cond". The simplest valid program that uses anything
defined in the prelude will not evaluate.

Comment 2 Horst H. von Brand 2004-06-22 10:27:26 EDT
The same here. Curiously, on FC1 fully up to date; with Arjan's 2.6
kernel machinery and self-configured vanilla 2.6.7-rc3 it seems to
work fine.
Comment 3 Asgeir Nilsen 2004-08-12 08:24:09 EDT
Same error for FC1.

Tried downloading the original tar file from http://www.cs.umb.edu/
~wrc/scheme/umb-scheme-3.2.tar.gz, and this fails also.

Steps to reproduce:

1. Download http://www.cs.umb.edu/~wrc/scheme/umb-scheme-3.2.tar.gz
2. vi +65 steering.c, #define STANDARD_PRELUDE_PATHNAME "./prelude.
scheme"
3. make
4. ./scheme

Welcome to UMB Scheme, version 3.2  Copyright (c) 1988,1996 William R 
Campbell.
UMB Scheme comes with ABSOLUTELY NO WARRANTY. This is free software 
and
you are free to redistribute it under certain conditions.
See the UMB Scheme Release Notes for details. Type Control-d to exit.

Loading ./prelude.scheme...

Fatal Error: Segmentation Violation.

Reset (Use Control-d to quit UMB Scheme)
==>
Comment 4 Jindrich Novy 2004-09-14 08:03:41 EDT
Hello Thomas, the error described is in the garbage collection macro
GC_Object() in architecture.c because of corrupted heap while
interpreting prelude.scheme. This is pretty hard to fix. Because
umb-scheme is planned to be removed from next release (and will be
replaced by slib), I won't fix this bug.

Jindrich
Comment 5 Jindrich Novy 2005-01-21 04:25:25 EST
*** Bug 145693 has been marked as a duplicate of this bug. ***
Comment 6 Horst H. von Brand 2005-01-21 08:22:00 EST
From comments to 122409 and 125921 it looks like umb-scheme is to be
discountinued, in favour of slib. But there is no slib package to be found.
Rawhide perhaps?
Comment 7 Jindrich Novy 2005-01-24 03:19:54 EST
Yes, you can download the slib package from one of the devel mirrors:
http://sunsite.mff.cuni.cz/pub/fedora/development/SRPMS/slib-3a1-2.src.rpm
Comment 8 Jindrich Novy 2005-01-25 10:41:02 EST
*** Bug 146109 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.