Bug 122414 - cdrom device not functional after upgrade
Summary: cdrom device not functional after upgrade
Status: CLOSED DUPLICATE of bug 116622
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 05:14 UTC by Joe Smith
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Smith 2004-05-04 05:14:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
After upgrading from fc1 to fc2_t3, one of my two cd drives was no
longer functional.  Once I removed the 'hdc=ide-scsi' option from the
the grub boot configuration, both drives work fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade FC1 to FC2 (*)
2. Try to use cd drive
3. Device not accessible

(*) May require two-drive system, or just a CD-writer that was
configured with 'hdx=ide-scsi' under FC1.


Actual Results:  CD device not accessible (not a valid block device).


Expected Results:  CD should work.

Additional info:

After upgrading from fc1 to fc2_t3, one of my two cd drives was no
longer functional: wouldn't play audio CDs; wouldn't mount data CDs. 
The other CD drive was functional; the non-functional drive was used
for the upgrade, so I know it works ;-)

At the next boot, I checked the grub boot configuration and noticed
that the previous kernel options had been copied to the new config,
including the 'hdc=ide-scsi' needed for my CD writer under fc1.  Once
I removed that option, both drives work fine.

I'm not sure what information is needed to 'fix' this; please let me
know if more specific info is required.

Comment 1 Jeremy Katz 2004-05-07 01:11:20 UTC

*** This bug has been marked as a duplicate of 116622 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:02:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.