Bug 122424 - FC2T3 grub config uses wrong hd during installation
FC2T3 grub config uses wrong hd during installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 08:13 EDT by Fred Zwarts
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 18:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Zwarts 2004-05-04 08:13:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; 
T312461; Q312461)

Description of problem:
For our Proliant Dl380 G3 system we have two hard disks. The internal 
smart array (cciss) and an external SAN disk (sda) interfaced with a 
Qlogic qla2300. We boot from the internal (cciss) disk. The BIOS of 
the qla2300 is disabled, because we do not boot from this disk. 
During the Fedora installation (and later during system startup as 
well) the qla2300 driver is loaded before the cciss driver.

After the installation, when we tried to boot the new system, grub 
gave a message that it could not find the disk and it mentioned hd1.
By changing this into hd0, we were able to boot the system. We also 
replaced everywhere in the grub configuration file hd1 with hd0. 
After that we could boot the system without manual intervention.

Our theory is that, because the qla2300 driver is loaded before the 
cciss driver during the installation qla2300 is mapped to hd0 and 
cciss is mapped to hd1. During the early boot process, the SAN disk 
is not available, because the qla2300 bios is not enabled, so there 
is no hd1 at that moment. So, the mapping to hd0 and hd1 should not 
only depend on the order in which the drivers are loaded, but also on 
the availability of the disks via the bios.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make sure both disks are available to the system and that the bios 
of the qla2300 is not enabled.
2. Run the installation and install the system on the cciss disk.
3. Try to boot the system.
    

Actual Results:  We see a boot failure, with a message that hd1 is 
not a valid disk.

Expected Results:  Display of the boot splash screen choser.

Additional info:
Comment 1 Jeremy Katz 2004-05-06 18:26:49 EDT
PC hardware doesn't provide an interface to determine what the BIOS
thinks the boot device is.  If you go into the advanced boot loader
options screen, anaconda allows the user to change the drive ordering
from our usually correct heuristic.

Note You need to log in before you can comment on or make changes to this bug.