Bug 122426 - Tomcat crashes on page access
Summary: Tomcat crashes on page access
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 12:42 UTC by Kees
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 16:37:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kees 2004-05-04 12:42:36 UTC
Description of problem:

After installing tomcat (tomcat-4.1.27-12, httpd-2.0.49-3) it starts 
correctly (from /var/log/tomcat/tomcat.out):

Bootstrap: Create Catalina server
StandardClassLoader: gcjlib URL support enabled (prefix="gcjlib:")
Created catalinaLoader in: /usr/share/tomcat/server/lib
[INFO] Registry - -Loading registry information
[INFO] Registry - -Creating new Registry instance
[INFO] Registry - -Creating MBeanServer
Bootstrap: Starting service
Starting service Tomcat-Standalone
Apache Tomcat/4.1.27-12
[INFO] ChannelSocket - -JK2: ajp13 listening on
localhost.localdomain/127.0.0.1:8009
[INFO] JkMain - -Jk running ID=0 time=20/40 
config=/usr/share/tomcat/conf/jk2.properties
Bootstrap: Service started


Then in the browser I type: http://127.0.0.1:8009/
I get a 404. And this is added to the log:

[ERROR] MsgAjp - -BAD packet signature 18245
47 45 54 20 00 00 00 00 00 00 00 00 00 00 00 00  | GET ............
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  | ................
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  | ................
<snip>
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  | ................
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  | ................
java.lang.NullPointerException
   at
org.apache.jk.common.ChannelSocket.processConnection(org.apache.jk.core.MsgContext)
(/usr/lib/lib-org-apache-jk-4.1.27.so)
   at org.apache.jk.common.SocketConnection.runIt(java.lang.Object[])
(/usr/lib/lib-org-apache-jk-4.1.27.so)
   at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run()
(/usr/lib/lib-org-apache-tomcat-util-4.1.27.so)
   at java.lang.Thread.run() (/usr/lib/libgcj.so.5.0.0)
   at _Jv_ThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.5.0.0)
   at GC_start_routine (/usr/lib/libgcj.so.5.0.0)
   at __clone (/lib/tls/libc-2.3.3.so)
[ERROR] ThreadPool - -Caught exception executing
org.apache.jk.common.SocketConnection@94f4b40, terminating thread
<java.lang.NullPointerException>

Comment 1 Gary Benson 2004-05-07 16:46:16 UTC
Could you try this using tomcat-4.1.27-13 please?

Comment 2 Kees 2004-05-07 16:57:20 UTC
Hi,
I yum erased all the tomcat stuff and installed the binary 4.1.30 from
jakarta.apache.org. That works.
I think the problem may be caused by mixing packages from the jpackage
repository since I needed eclipse.
I will install FC2t3 in a VM and I'll try again soon.

Comment 3 Kees 2004-05-07 18:18:24 UTC
Tried -13. Same problem.


Comment 4 Gary Benson 2004-05-10 16:37:35 UTC
Doh, I must have been asleep when I looked at this before.  Tomcat in
FC2 is set up to listen for AJP 1.3 connections on port 8009, and you
need to connect to it using mod_jk2.  If you need to use HTTP directly
then you should enable the appropriate connector in
/etc/tomcat/server.xml and restart tomcat.


Note You need to log in before you can comment on or make changes to this bug.