Bug 122430 - All programs with use libasound.so.2 fails
All programs with use libasound.so.2 fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 09:52 EDT by André Nazário de Souza
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 13:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description André Nazário de Souza 2004-05-04 09:52:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
esd and other programs with use libasound.so.2 return this error :

esd: error while loading shared libraries: /usr/lib/libasound.so.2:
unexpected PLT reloc type 0x00

xmms simple broken.


Version-Release number of selected component (if applicable):
alsa-lib-1.0.3a-1

How reproducible:
Always

Steps to Reproduce:
1. exec esd
2.
3.
    

Actual Results:  esd: error while loading shared libraries:
/usr/lib/libasound.so.2: unexpected PLT reloc type 0x00


Expected Results:  esd linten for connections

Additional info:
Comment 1 Bill Nottingham 2004-05-04 10:51:44 EDT
What does rpm -V alsa-lib say for you?
Comment 2 André Nazário de Souza 2004-05-04 11:59:13 EDT
[samoied@patinhas samoied]$ rpm -V alsa-lib
prelink: /usr/bin/alsalisp: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/alsalisp
prelink: /usr/bin/aserver: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/aserver
prelink: /usr/lib/libasound.so.2.0.0: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/libasound.so.2.0.0
Comment 3 André Nazário de Souza 2004-05-04 12:01:41 EDT
This is the correct:

[root@panthro root]# rpm -V alsa-lib
prelink: /usr/bin/alsalisp: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/bin/alsalisp
prelink: /usr/bin/aserver: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/bin/aserver
..5.....    /usr/lib/libasound.so.2.0.0
Comment 4 Bill Nottingham 2004-05-04 12:02:42 EDT
What happens if you reinstall the RPM?
Comment 5 André Nazário de Souza 2004-05-04 12:24:00 EDT
Yes, the esd listen...
But the xmms when connect to one esd(esound-0.2.31-1 - FC1) give this
message:
[samoied@panthro samoied]$ xmms

audio_alsa: no cards found!
 
Erro de segmentação
 
Você provavelmente acaba de encontrar um bug no XMMS. Por favor,
visite http://bugs.xmms.org e notifique-nos fazendo
um relatório de bug.
 
Xlib: unexpected async reply (sequence 0x9d2)!

Comment 6 André Nazário de Souza 2004-05-04 12:26:18 EDT
I forgot it:

the esd give this message:

[samoied@panthro samoied]$ esd
audio_alsa: no cards found!
Comment 7 André Nazário de Souza 2004-05-04 12:30:29 EDT
But if I run with root:

[root@panthro root]# esd
 
No problems!
Comment 8 André Nazário de Souza 2004-05-04 12:42:09 EDT
Ow! The was resolved using default port:

On server:

esd -bind 172.19.219.35 -tcp

On client:
Configure xmms to use this ip and port 16001.

I was used port 6666 and xmms crashs.
Comment 9 Marcin Garski 2004-10-25 07:52:20 EDT
There is a bug in XMMS, when you set esd output on remote host with
NOT default port 16001, XMMS will crash.

I've already fil a bug in XMMS bugzilla:
http://bugs.xmms.org/show_bug.cgi?id=1922

Bill, I think this bug could be closed, but maybe you want to check
something with prelinking (so I'll leave it as NEW)?
Comment 10 Bill Nottingham 2004-10-25 13:39:58 EDT
The prelinking thing I haven't seen elsewhere, so I'm presuming it's a
temporary glitch unless it comes back. Hence, closing -> upstream. 

Note You need to log in before you can comment on or make changes to this bug.