Bug 122435 - join -t doesn't work
join -t doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 10:35 EDT by Mikel Ward
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-09 05:41:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2004-05-04 10:35:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040422 Epiphany/1.2.4

Description of problem:
As of coreutils 5.2, join's -t flag doesn't appear to work, instead
it hangs.

Version-Release number of selected component (if applicable):
coreutils-5.2.1-6

How reproducible:
Always

Steps to Reproduce:
Create two files:
file1
1:Ben
2:Mike
3:Scott

file2
1:Beer
2:Coke
3:Whisky

Run:
join -t ':' file1 file2

Actual Results:  Hangs.

Expected Results:  Following is output to standard out:
1:Ben:Beer
2:Mike:Coke
3:Scott:Whisky

Additional info:

Didn't double check this test case, but you get the idea.  Bug exhibits
itself on my actual data.

This worked for me in coreutils 5.0 (and therefore presumably coreutils
as shipped with Fedora Core 1).
Comment 1 Tim Waugh 2004-05-04 10:46:20 EDT
Confirmed.  Thanks for the report.
Comment 2 Tim Waugh 2004-05-04 12:34:08 EDT
Fixed in coreutils-5.2.1-7.  Once it shows up in the daily development
push (it'll be tomorrow now), please verify that it works for you and
resolve this bug 'RAWHIDE' if so.  Thanks.
Comment 3 Mikel Ward 2004-05-09 05:41:28 EDT
Works for me now, so it seems to be fixed.

Thanks for the quick turnaround.

Note You need to log in before you can comment on or make changes to this bug.