Bug 122441 - [PATCH] Make clusvcmgrd relocate services it can't run b/c of RFD
Summary: [PATCH] Make clusvcmgrd relocate services it can't run b/c of RFD
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 15:40 UTC by Lon Hohberger
Modified: 2009-04-16 20:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 21:22:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which fixes problem. (1.12 KB, patch)
2004-05-04 15:41 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2004:239 normal SHIPPED_LIVE Updated clumanager package adds support for GFS mounts 2004-06-25 04:00:00 UTC

Description Lon Hohberger 2004-05-04 15:40:10 UTC
When clusvcmgrd gets a request to start a service and it can't because
of a failover-domain restriction, it currently simply returns failure
with no action taken.

This patch alters clusvcmgrd's behavior to mimic normal service start
failures: it attempts to relocate the service to cluster members which
are allowed run it.

Comment 1 Lon Hohberger 2004-05-04 15:41:04 UTC
Created attachment 99955 [details]
Patch which fixes problem.

Comment 3 Lon Hohberger 2004-05-04 15:51:07 UTC
I. Requirements/setup
  A. Requirements
    1. 2 node cluster (ex: {magenta, yellow})
    2. a restricted failover domain comprised of one of the members
       (ex: {magenta})
    3. a service bound to the above domain. (ex: "testing")
  B. Setup
    1. Start cluster software on both members.
    2. Fire up redhat-config-cluster on member NOT specified in I.A.2.
       (in our case, yellow)

II. Old behavior
  A. Steps
    1. Click Service defined in I.A.3.
    2. Click "Disable" button.
    3. Click "Enable" button.
  B. Result
    1. Service will not start.
    2. clusvcadm output:

       Member yellow enabling testing...failed

III.  New Behavior
  A. Ditto.
  B. Result
    1. Service starts on member in RFD defined in I.A.2.
    2. clusvcadm reports:

       Member yellow trying to enable testing...success
       Note: Service testing failed to start on yellow.
       Service testing is now running on magenta.

Comment 4 Mike McLean 2004-06-25 21:22:15 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-239.html


Comment 5 Lon Hohberger 2007-12-21 15:09:56 UTC
Fixing product name.  Clumanager on RHEL3 was part of RHCS3, not RHEL3


Note You need to log in before you can comment on or make changes to this bug.