Bug 122451 - When viewing system log, a new event causes screen to rescroll.
Summary: When viewing system log, a new event causes screen to rescroll.
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-logviewer   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 122626 138867 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 17:29 UTC by Bob Gustafson
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-16 14:29:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Gustafson 2004-05-04 17:29:38 UTC
Description of problem:

  I am studying the log file - having scrolled to the line of interest.

  Some loggable system event happens - a new line appears at the
bottom of the list, but then the whole list rescrolls - and the window
shown is the beginning of the file, not where I was looking. Not helpful.

Version-Release number of selected component (if applicable):

  FC2(Test3) up-to-date

  /usr/bin/system-logviewer --version

  No version number shown

How reproducible:

  Always

Steps to Reproduce:

1.System Tools -> System Logs
2.select System Log.
3.scroll to the middle of the list
4.wait for a (short) time until a new loggable event happens
5.observe that you are now looking at the beginning of log, not middle
  
Actual results:
  As discussed above

Expected results:
  When I am looking at the system logs, I don't want them to 'move'.

  Perhaps there could be an added 'mode' button on the GUI - with two
settings:

  restore viewing position after new event
  view latest lines as they come

Additional info:

Comment 1 Chris Lumens 2004-11-19 18:37:20 UTC
*** Bug 122626 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2004-11-19 18:38:53 UTC
*** Bug 138867 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2005-06-16 14:29:23 UTC
system-logviewer has been removed from Core.


Note You need to log in before you can comment on or make changes to this bug.