Bug 122460 - php can't be recompiled with curl version from test3 release
php can't be recompiled with curl version from test3 release
Status: CLOSED DUPLICATE of bug 120513
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On: 121011
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 15:25 EDT by Michal Ambroz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2004-05-04 15:25:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.14

Description of problem:
The PHP version (php-4.3.4-11) included in the test3 release of Fedora
Core 2 can't be recompiled with the curl version included in this
release (curl-7.11.1-1).

This should be fixed to the final release.

Rebuild log looks like this:
php-4.3.4/ext/curl/curl.c: In function `curl_free_post':
php-4.3.4/ext/curl/curl.c:563: warning: passing arg 1 of
`curl_formfree' from incompatible pointer type
php-4.3.4/ext/curl/curl.c: In function `alloc_curl_handle':
php-4.3.4/ext/curl/curl.c:603: error: invalid application of `sizeof'
to an incomplete type
php-4.3.4/ext/curl/curl.c: In function `zif_curl_setopt':
php-4.3.4/ext/curl/curl.c:838: error: duplicate case value
php-4.3.4/ext/curl/curl.c:695: error: previously used here
php-4.3.4/ext/curl/curl.c:883: warning: passing arg 1 of
`curl_formadd' from incompatible pointer type
php-4.3.4/ext/curl/curl.c:883: warning: passing arg 2 of
`curl_formadd' from incompatible pointer type
php-4.3.4/ext/curl/curl.c:891: warning: passing arg 1 of
`curl_formadd' from incompatible pointer type
php-4.3.4/ext/curl/curl.c:891: warning: passing arg 2 of
`curl_formadd' from incompatible pointer type
make: *** [ext/curl/curl.lo] Error 1

More details in bugreports:
120513
104685

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild php-4.3.4-11.src.rpm

    

Actual Results:  rebuild process fails

Expected Results:  Rebuild should succede

Additional info:
Comment 1 Martin Ebourne 2004-05-04 18:45:03 EDT
This is php bug: http://bugs.php.net/bug.php?id=27663
Included in the bug report is a patch which fixed the SRPM for me.
Comment 2 Joe Orton 2004-05-05 08:44:37 EDT
Thanks.  This was fixed in the upgrade to 4.3.6, but 4.3.6 had issues
so we had to back down to the 4.3.4 package again.
Comment 3 Joe Orton 2004-05-24 15:10:01 EDT

*** This bug has been marked as a duplicate of 120513 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.