Bug 122463 - yum tries to install wrong version of openssl-devel
yum tries to install wrong version of openssl-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 16:16 EDT by Robin Green
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 16:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my yum.conf (2.22 KB, text/plain)
2004-05-05 02:56 EDT, Robin Green
no flags Details
compressed output of yum -d 6 update (36.08 KB, application/gzip)
2004-05-05 02:59 EDT, Robin Green
no flags Details

  None (edit)
Description Robin Green 2004-05-04 16:16:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
This is on FC1 fully patched.

When I type yum install openssl-devel, yum tries to install
openssl-devel from base instead of from updates, and then tries to
downgrade openssl to match it. Except it doesn't tell rpm it's trying
to downgrade, so it fails (See log below).

The fedora updates-released repo is in my yum.conf, and is not
commented out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install openssl from updates, but not openssl-devel or pam-devel
2. Run yum install openssl-devel pam-devel


Actual Results:
[greenrd@fedora rpm]$ sudo yum install openssl-devel pam-devel
Unable to find pid
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
Server: Fedora.us extra packages for Fedora Core 1 - i386
Server: Hipnosi.net
Server: JPackage 1.5 for Fedora Core 1
Server: JPackage 1.5, generic
retrygrab() failed for:
 
ftp://us.dl.sf.net/pub/sourceforge/jpackage/direct_download/1.5/generic/free/headers/header.info
  Executing failover method
Server: JPackage 1.5, non-free section
Server: Fedora Compatible Packages (stable)
Server: Fedora Core 1 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
..Dependencies resolved
I will do the following:
[install: pam-devel 0.77-15.i386]
[install: openssl-devel 0.9.7a-23.i386]
I will install/upgrade these to satisfy the dependencies:
[deps: krb5-devel 1.3.1-6.i386]
[deps: openssl 0.9.7a-23.i386]
[deps: e2fsprogs-devel 1.34-1.i386]
Is this ok [y/N]: y
Getting pam-devel-0.77-15.i386.rpm
pam-devel-0.77-15.i386.rp 100% |=========================|  76 kB    00:00
Getting openssl-devel-0.9.7a-23.i386.rpm
openssl-devel-0.9.7a-23.i 100% |=========================| 1.6 MB    00:01
Getting krb5-devel-1.3.1-6.i386.rpm
krb5-devel-1.3.1-6.i386.r 100% |=========================| 820 kB    00:01
Getting openssl-0.9.7a-23.i386.rpm
retrygrab() failed for:
 
ftp://ftp.ens.utulsa.edu/pub/linux/fedora/core/1/i386/os/Fedora/RPMS/openssl-0.9.7a-23.i386.rpm
  Executing failover method
retrygrab() failed for:
 
ftp://mirror.web-ster.com/fedora/os/core/1/i386/os/Fedora/RPMS/openssl-0.9.7a-23.i386.rpm
  Executing failover method
openssl-0.9.7a-23.i386.rp 100% |=========================| 1.1 MB    04:21
Getting e2fsprogs-devel-1.34-1.i386.rpm
e2fsprogs-devel-1.34-1.i3 100% |=========================| 137 kB    00:01
Running test transaction:
Errors reported doing trial run
package openssl-0.9.7a-33.10 (which is newer than openssl-0.9.7a-23)
is already installed


Expected Results:  It should have said:

I will do the following:
[install: pam-devel 0.77-15.i386]
[install: openssl-devel 0.9.7a-33.10]
I will install/upgrade these to satisfy the dependencies:
[deps: krb5-devel 1.3.1-6.i386]
[deps: e2fsprogs-devel 1.34-1.i386]


Additional info:

[root@fedora etc]# grep openssl /var/cache/yum/*/header.info
/var/cache/yum/base/header.info:0:openssl-0.9.7a-23.i686=Fedora/RPMS/openssl-0.9.7a-23.i686.rpm
/var/cache/yum/base/header.info:0:openssl096b-0.9.6b-14.i386=Fedora/RPMS/openssl096b-0.9.6b-14.i386.rpm
/var/cache/yum/base/header.info:0:openssl-perl-0.9.7a-23.i386=Fedora/RPMS/openssl-perl-0.9.7a-23.i386.rpm
/var/cache/yum/base/header.info:0:openssl-0.9.7a-23.i386=Fedora/RPMS/openssl-0.9.7a-23.i386.rpm
/var/cache/yum/base/header.info:0:openssl096-0.9.6-24.i386=Fedora/RPMS/openssl096-0.9.6-24.i386.rpm
/var/cache/yum/base/header.info:0:openssl-devel-0.9.7a-23.i386=Fedora/RPMS/openssl-devel-0.9.7a-23.i386.rpm
/var/cache/yum/updates-released/header.info:0:openssl096-0.9.6-26.i386=openssl096-0.9.6-26.i386.rpm
/var/cache/yum/updates-released/header.info:0:openssl-0.9.7a-33.10.i386=openssl-0.9.7a-33.10.i386.rpm
/var/cache/yum/updates-released/header.info:0:openssl-perl-0.9.7a-33.10.i386=openssl-perl-0.9.7a-33.10.i386.rpm
/var/cache/yum/updates-released/header.info:0:openssl-0.9.7a-33.10.i686=openssl-0.9.7a-33.10.i686.rpm
/var/cache/yum/updates-released/header.info:0:openssl-devel-0.9.7a-33.10.i386=openssl-devel-0.9.7a-33.10.i386.rpm
/var/cache/yum/updates-released/header.info:0:openssl096b-0.9.6b-18.i386=openssl096b-0.9.6b-18.i386.rpm
Comment 1 Seth Vidal 2004-05-04 22:12:29 EDT
what arch is your system? 
run 
cat /proc/cpuinfo
and send the output

also run these two commands and send the output please:
rpm -q --qf  "%{name} %{arch}\n" openssl kernel

thanks - the error you're seeing is not a 'downgrade process' yum will
not downgrade packages, at all.
Comment 2 Robin Green 2004-05-04 23:01:07 EDT
# cat /proc/cpuinfo
processor       : 0
vendor_id       : User Mode Linux
model name      : UML
mode            : skas
host            : Linux munich.redwoodvirtual.com
2.4.24-skas3libatapre2 #1 SMP Fri Jan 23 20:36:33 UTC 2004 i686
bogomips        : 2951.94

The UML kernel is maintained by my hosting provider outside of my
virtual machine, and not using rpm, by the way.

# rpm -q --qf  "%{name} %{arch}\n" openssl kernel
openssl i686
kernel i686
kernel i686
Comment 3 Seth Vidal 2004-05-04 23:58:36 EDT
ok
attach your yum.conf and the output of
yum -d 6 update
thanks
Comment 4 Robin Green 2004-05-05 02:56:05 EDT
Created attachment 99983 [details]
my yum.conf
Comment 5 Robin Green 2004-05-05 02:59:39 EDT
Created attachment 99984 [details]
compressed output of yum -d 6 update
Comment 6 Seth Vidal 2004-05-05 03:00:36 EDT
why did you turn exactarch off?

this failure to update might be due to a 'partial' update to a newer
openssl but not the right architecture.
Comment 7 Robin Green 2004-05-05 03:05:31 EDT
In my yum.conf, exactarch used to be 1, but I changed it to 0 to see
if it would make the bug go away. (I don't understand what exactarch
does, from reading the man page.) The change didn't affect the bug
though, the bug still happened.

Is i686 not the right architecture for openssl? After all, ssl can be
quite cpu-intensive... it makes sense to use the optimised package,
surely?
Comment 8 Seth Vidal 2004-05-05 03:35:41 EDT
a couple more items

rpm -q openssl
rpm -q openssl-devel

I just want to make sure I know what you have installed now.

thanks
Comment 9 Robin Green 2004-05-05 03:45:26 EDT
openssl-0.9.7a-33.10
package openssl-devel is not installed
Comment 10 Seth Vidal 2004-05-05 03:53:11 EDT
something is screwy here.
I can get this to occur, but only if I disable the updates-released
repository and have the updated openssl installed.

The version comparisons in your debug file  are coming out correctly,
at least apparently so.

Have you made any other modifications to rpm or yum on this system?
What version of yum is this?
Comment 11 Seth Vidal 2004-05-05 04:09:36 EDT
ok,  I think I see some more of what is going on.

can you run:

yum -d 4 install openssl-devel now

and tell me what it does.

I think one of your mirrors of the updates-released was not correct
and you were temporarily getting an empty header.info and/or something
else entirely.

the reason why the yum -d 6 output is correct is b/c you're not seeing
that problem with the updates-released repository any more.

so for the time you ran the yum install openssl-devel there were
different packages available than a later time.

I'm going to take a look at making it some yum will consider a
downgrade to install an unresolveable dep and bail out.
Comment 12 Robin Green 2004-05-05 16:07:50 EDT
I have made no modifications to rpm or yum. Versions are:

yum-2.0.5-1
rpm-4.2.1-0.30
python-2.2.3-7

running yum -d 4 install openssl-devel now yields the same bug: (NOTE
two contradictary answers for "Best version for openssl" in output!)

<snip>
Finding updated packages
putting mod_jk2 in complex update list
putting openssl in complex update list
putting kernel in complex update list
putting glibc in complex update list
Best version for mod_jk2 is 0:2.0.4-5hip
Best version for mod_jk2 is 0:2.0.4-5hip
Best version for openssl is 0:0.9.7a-23
Best version for openssl is 0:0.9.7a-33.10
Best version for kernel is 0:2.4.22-1.2174.nptl
Best version for kernel is 0:2.4.22-1.2188.nptl
Best version for glibc is 0:2.3.2-101.4
Best version for glibc is 0:2.3.2-101.4
Downloading needed headers
getting
/var/cache/yum/fedora-us-1-stable/headers/easytag-0-0.30.2-0.fdr.1.1.i386.hdr
failover: baseURL =
ftp://mirrors.kernel.org/fedora.us/fedora/fedora/1/i386/yum/stable
failover: path = /headers/easytag-0-0.30.2-0.fdr.1.1.i386.hdr
easytag-0-0.30.2-0.fdr.1. 100% |=========================| 3.3 kB    00:00
putting mod_jk2 in complex update list
putting openssl in complex update list
putting kernel in complex update list
putting glibc in complex update list
Best version for mod_jk2 is 0:2.0.4-5hip
Best version for mod_jk2 is 0:2.0.4-5hip
Best version for openssl is 0:0.9.7a-23
Best version for openssl is 0:0.9.7a-33.10
Best version for kernel is 0:2.4.22-1.2174.nptl
Best version for kernel is 0:2.4.22-1.2188.nptl
Best version for glibc is 0:2.3.2-101.4
Best version for glibc is 0:2.3.2-101.4
Downloading needed headers
getting
/var/cache/yum/fedora-us-1-stable/headers/easytag-0-0.30.2-0.fdr.1.1.i386.hdr
failover: baseURL =
ftp://mirrors.kernel.org/fedora.us/fedora/fedora/1/i386/yum/stable
failover: path = /headers/easytag-0-0.30.2-0.fdr.1.1.i386.hdr
easytag-0-0.30.2-0.fdr.1. 100% |=========================| 3.3 kB    00:00
putting mod_jk2 in complex update list
putting openssl in complex update list
putting kernel in complex update list
putting glibc in complex update list
Best version for mod_jk2 is 0:2.0.4-5hip
Best version for mod_jk2 is 0:2.0.4-5hip
Best version for openssl is 0:0.9.7a-23
Best version for openssl is 0:0.9.7a-33.10
Best version for kernel is 0:2.4.22-1.2174.nptl
Best version for kernel is 0:2.4.22-1.2188.nptl
Best version for glibc is 0:2.3.2-101.4
Best version for glibc is 0:2.3.2-101.4
nulist = 2392
uplist = 0
newlist = 2392
obsoleting = 0
obsoleted = 0
state - iu: openssl-devel, i386
Cannot find a package matching now
Resolving dependencies
Updating: openssl-devel, i386
Updating: openssl-devel, i386
# of Deps = 2
debug dep: openssl-devel req krb5-devel - None - 0
openssl-devel wants Fedora/RPMS/krb5-devel-1.3.1-6.i386.rpm
Best version for krb5-devel is 0:1.3.1-6
bestarch = i386 for krb5-devel
Got dep: krb5-devel, i386
debug dep: openssl-devel req openssl - 0.9.7a-23 - 0
openssl-devel wants Fedora/RPMS/openssl-0.9.7a-23.i386.rpm
Best version for openssl is 0:0.9.7a-23
bestarch = i386 for openssl
Got dep: openssl, i386
Restarting Dependency Loop
.Updating: openssl-devel, i386
Updating: krb5-devel, i386
Updating: openssl, i386
# of Deps = 1
debug dep: krb5-devel req e2fsprogs-devel - None - 0
krb5-devel wants Fedora/RPMS/e2fsprogs-devel-1.34-1.i386.rpm
Best version for e2fsprogs-devel is 0:1.34-1
bestarch = i386 for e2fsprogs-devel
Got dep: e2fsprogs-devel, i386
Restarting Dependency Loop
.Updating: openssl-devel, i386
Updating: krb5-devel, i386
Updating: openssl, i386
Updating: e2fsprogs-devel, i386
Dependencies resolved
I will do the following:
[install: openssl-devel 0.9.7a-23.i386]
I will install/upgrade these to satisfy the dependencies:
[deps: krb5-devel 1.3.1-6.i386]
[deps: openssl 0.9.7a-23.i386]
[deps: e2fsprogs-devel 1.34-1.i386]
Is this ok [y/N]: n
Exiting on user command.
Comment 13 Jeff Johnson 2004-06-09 22:36:57 EDT
Please make sure that /etc/rpm/platform has the correct arch
for your platform.

On i686, /etc/rpm/platform should contain:
   i686-redhat-linux

If the problem was not /etc/rpm/platform, please reopen.
Comment 14 Robin Green 2004-06-10 03:22:52 EDT
It does contain i686-redhat-linux
Comment 15 Jeff Johnson 2004-06-10 17:32:27 EDT
Hmmm, something is very screwy here, and I do not see where.

I can, however, tell you how to work around the problem.

Download the openssl packages you want and install from the
command line using
   rpm -Uvh openssl*.rpm

If that fails append the failure here and I'll tell
you which other packages are needed (you can do this too)
by installing the rpmdb-fedora package, and then typing
    rpm -q --redhatprovides ...
for each failed dependency, and then adding that to the rpm -Uvh
transaction.

NEEDINFO for the workaround. I shall see if I can figger the yum
problem too.
Comment 16 Robin Green 2004-06-16 20:05:18 EDT
I have done that to work around it already. I just thought I'd let you
guys know about the bug.

Note You need to log in before you can comment on or make changes to this bug.